summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-11-29 07:46:23 +0100
committerRemi Collet <remi@remirepo.net>2017-11-29 07:46:23 +0100
commit18b292eb9b5731204adc46fe65901f04c9fa3a97 (patch)
tree0cd57d280ce1acf41feb313b8e3ba64da02826ea
parent39f3f6ce843c1e85414788cfb0b4ecf64e0551d5 (diff)
Update to 2.7.0
raise dependency on PHP 5.6 use phpunit6 on F26+
-rw-r--r--.gitignore8
-rw-r--r--composer.json42
-rw-r--r--php-zendframework-zend-mime.spec52
3 files changed, 57 insertions, 45 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/composer.json b/composer.json
index 3be2356..8bfed71 100644
--- a/composer.json
+++ b/composer.json
@@ -1,35 +1,35 @@
{
"name": "zendframework/zend-mime",
- "description": " ",
+ "description": "Create and parse MIME messages and parts",
"license": "BSD-3-Clause",
"keywords": [
- "zf2",
+ "zendframework",
+ "zf",
"mime"
],
- "homepage": "https://github.com/zendframework/zend-mime",
- "autoload": {
- "psr-4": {
- "Zend\\Mime\\": "src/"
- }
+ "support": {
+ "docs": "https://docs.zendframework.com/zend-mime/",
+ "issues": "https://github.com/zendframework/zend-mime/issues",
+ "source": "https://github.com/zendframework/zend-mime",
+ "rss": "https://github.com/zendframework/zend-mime/releases.atom",
+ "slack": "https://zendframework-slack.herokuapp.com",
+ "forum": "https://discourse.zendframework.com/c/questions/components"
},
"require": {
- "php": "^5.5 || ^7.0",
+ "php": "^5.6 || ^7.0",
"zendframework/zend-stdlib": "^2.7 || ^3.0"
},
"require-dev": {
"zendframework/zend-mail": "^2.6",
- "phpunit/PHPUnit": "^4.7 || ^5.7",
+ "phpunit/PHPUnit": "^5.7.21 || ^6.3",
"zendframework/zend-coding-standard": "~1.0.0"
},
"suggest": {
"zendframework/zend-mail": "Zend\\Mail component"
},
- "minimum-stability": "dev",
- "prefer-stable": true,
- "extra": {
- "branch-alias": {
- "dev-master": "2.6-dev",
- "dev-develop": "2.7-dev"
+ "autoload": {
+ "psr-4": {
+ "Zend\\Mime\\": "src/"
}
},
"autoload-dev": {
@@ -37,6 +37,15 @@
"ZendTest\\Mime\\": "test/"
}
},
+ "config": {
+ "sort-packages": true
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.7-dev",
+ "dev-develop": "2.8-dev"
+ }
+ },
"scripts": {
"check": [
"@cs-check",
@@ -47,5 +56,6 @@
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
"upload-coverage": "coveralls -v"
- }
+ },
+ "homepage": "https://github.com/zendframework/zend-mime"
}
diff --git a/php-zendframework-zend-mime.spec b/php-zendframework-zend-mime.spec
index 00d7687..e04b951 100644
--- a/php-zendframework-zend-mime.spec
+++ b/php-zendframework-zend-mime.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 9e53a97a3c190d45cc5d584daaaf487d509a9285
+%global gh_commit 5db38e92f8a6c7c5e25c8afce6e2d0bd49340c5f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-mime
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.6.1
+Version: 2.7.0
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -30,29 +30,33 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.5
+BuildRequires: php(language) >= 5.6
BuildRequires: php-iconv
BuildRequires: php-pcre
BuildRequires: php-spl
BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
# From composer, "require-dev": {
# "zendframework/zend-mail": "^2.6"",
-# "phpunit/PHPUnit": "^4.7 || ^5.7",
+# "phpunit/PHPUnit": "^5.7.21 || ^6.3",
# "zendframework/zend-coding-standard": "~1.0.0"
BuildRequires: php-composer(%{gh_owner}/zend-mail) >= 2.6
-BuildRequires: php-composer(phpunit/phpunit) >= 4.7
+%if 0%{?fedora} >= 26
+%global phpunit %{_bindir}/phpunit6
+%else
+%global phpunit %{_bindir}/phpunit
+%endif
+BuildRequires: %{phpunit}
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": "^5.5 || ^7.0",
+# "php": "^5.6 || ^7.0",
# "zendframework/zend-stdlib": "^2.7 || ^3.0"
-Requires: php(language) >= 5.5
+Requires: php(language) >= 5.6
%if ! %{bootstrap}
Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
@@ -91,8 +95,6 @@ mv LICENSE.md LICENSE
%install
-rm -rf %{buildroot}
-
mkdir -p %{buildroot}%{php_home}/Zend/
cp -pr src %{buildroot}%{php_home}/Zend/%{library}
@@ -112,33 +114,20 @@ Zend\Loader\AutoloaderFactory::factory(array(
require_once '%{php_home}/Zend/autoload.php';
EOF
-# remirepo:11
-run=0
ret=0
-if which php56; then
- php56 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if which php71; then
- php71 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --verbose
-# remirepo:2
-fi
+for cmd in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+ if which $cmd; then
+ set $cmd
+ $1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -147,6 +136,11 @@ rm -rf %{buildroot}
%changelog
+* Wed Nov 29 2017 Remi Collet <remi@remirepo.net> - 2.7.0-1
+- Update to 2.7.0
+- raise dependency on PHP 5.6
+- use phpunit6 on F26+
+
* Mon Jan 16 2017 Remi Collet <remi@fedoraproject.org> - 2.6.1-1
- update to 2.6.1