summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-01-17 06:04:07 +0100
committerRemi Collet <fedora@famillecollet.com>2017-01-17 06:04:07 +0100
commit39f3f6ce843c1e85414788cfb0b4ecf64e0551d5 (patch)
treeea57f0dd8a7ae8eedbc55aa3244af8792932f5fa
parent50de836f61b48d6304149f0c756322a91fbcafc4 (diff)
php-zendframework-zend-mime: 2.6.1
-rw-r--r--composer.json15
-rw-r--r--php-zendframework-zend-mime.spec32
2 files changed, 36 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index b04e9ff..3be2356 100644
--- a/composer.json
+++ b/composer.json
@@ -18,8 +18,8 @@
},
"require-dev": {
"zendframework/zend-mail": "^2.6",
- "fabpot/php-cs-fixer": "1.7.*",
- "phpunit/PHPUnit": "~4.0"
+ "phpunit/PHPUnit": "^4.7 || ^5.7",
+ "zendframework/zend-coding-standard": "~1.0.0"
},
"suggest": {
"zendframework/zend-mail": "Zend\\Mail component"
@@ -36,5 +36,16 @@
"psr-4": {
"ZendTest\\Mime\\": "test/"
}
+ },
+ "scripts": {
+ "check": [
+ "@cs-check",
+ "@test"
+ ],
+ "cs-check": "phpcs",
+ "cs-fix": "phpcbf",
+ "test": "phpunit --colors=always",
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
+ "upload-coverage": "coveralls -v"
}
}
diff --git a/php-zendframework-zend-mime.spec b/php-zendframework-zend-mime.spec
index 2b7ee1b..00d7687 100644
--- a/php-zendframework-zend-mime.spec
+++ b/php-zendframework-zend-mime.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 340769c3d962ac4d9d3cf9da7e75419368e56fcc
+%global gh_commit 9e53a97a3c190d45cc5d584daaaf487d509a9285
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-mime
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.6.0
+Version: 2.6.1
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -41,10 +41,10 @@ BuildRequires: php-spl
BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
# From composer, "require-dev": {
# "zendframework/zend-mail": "^2.6"",
-# "fabpot/php-cs-fixer": "1.7.*",
-# "phpunit/PHPUnit": "~4.0"
+# "phpunit/PHPUnit": "^4.7 || ^5.7",
+# "zendframework/zend-coding-standard": "~1.0.0"
BuildRequires: php-composer(%{gh_owner}/zend-mail) >= 2.6
-BuildRequires: php-composer(phpunit/phpunit) >= 4.0
+BuildRequires: php-composer(phpunit/phpunit) >= 4.7
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
@@ -112,11 +112,22 @@ Zend\Loader\AutoloaderFactory::factory(array(
require_once '%{php_home}/Zend/autoload.php';
EOF
-%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
-
-if which php70; then
- php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
+# remirepo:11
+run=0
+ret=0
+if which php56; then
+ php56 %{_bindir}/phpunit || ret=1
+ run=1
+fi
+if which php71; then
+ php71 %{_bindir}/phpunit || ret=1
+ run=1
fi
+if [ $run -eq 0 ]; then
+%{_bindir}/phpunit --verbose
+# remirepo:2
+fi
+exit $ret
%else
: Test suite disabled
%endif
@@ -136,6 +147,9 @@ rm -rf %{buildroot}
%changelog
+* Mon Jan 16 2017 Remi Collet <remi@fedoraproject.org> - 2.6.1-1
+- update to 2.6.1
+
* Thu Apr 21 2016 Remi Collet <remi@fedoraproject.org> - 2.6.0-1
- update to 2.6.0
- raise dependency on PHP >= 5.5