summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-05-11 19:32:21 +0200
committerRemi Collet <fedora@famillecollet.com>2016-05-11 19:32:21 +0200
commit5c13ce767223497534b689702f9ae4c7049d68e8 (patch)
treed893020b5b4d4ccc6f5137c1652c357877721494
parent4b03fd97e60ba3f6fc29694f4cd8d5107c923957 (diff)
php-zendframework-zend-memory: 2.5.2
-rw-r--r--composer.json50
-rw-r--r--php-zendframework-zend-memory.spec38
2 files changed, 71 insertions, 17 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..22c9283
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,50 @@
+{
+ "name": "zendframework/zend-memory",
+ "description": " ",
+ "license": "BSD-3-Clause",
+ "keywords": [
+ "zf2",
+ "memory"
+ ],
+ "homepage": "https://github.com/zendframework/zend-memory",
+ "autoload": {
+ "psr-4": {
+ "Zend\\Memory\\": "src/"
+ }
+ },
+ "require": {
+ "php": "^5.5 || ^7.0"
+ },
+ "require-dev": {
+ "zendframework/zend-cache": "^2.7",
+ "squizlabs/php_codesniffer": "^2.3.1",
+ "phpunit/PHPUnit": "^4.8"
+ },
+ "suggest": {
+ "zendframework/zend-cache": "To support swapping memory objects into and out of non-memory cache storage"
+ },
+ "minimum-stability": "dev",
+ "prefer-stable": true,
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.5-dev",
+ "dev-develop": "2.6-dev"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "ZendTest\\Memory\\": "test/"
+ }
+ },
+ "scripts": {
+ "check": [
+ "@cs-check",
+ "@test"
+ ],
+ "upload-coverage": "coveralls -v",
+ "cs-check": "phpcs",
+ "cs-fix": "phpcbf",
+ "test": "phpunit",
+ "test-coverage": "phpunit --coverage-clover clover.xml"
+ }
+}
diff --git a/php-zendframework-zend-memory.spec b/php-zendframework-zend-memory.spec
index 7189194..a845156 100644
--- a/php-zendframework-zend-memory.spec
+++ b/php-zendframework-zend-memory.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit ea25879c367ce2c13568640572fb79e882f5fc97
+%global gh_commit bbf8b9509660b2a97f2d6ccfefabffac3cca6a5c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-memory
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.5.1
+Version: 2.5.2
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -34,24 +34,24 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.3.23
+BuildRequires: php(language) >= 5.5
BuildRequires: php-spl
# From composer, "require-dev": {
-# "zendframework/zend-cache": "~2.5",
-# "fabpot/php-cs-fixer": "1.7.*",
-# "phpunit/PHPUnit": "~4.0"
-BuildRequires: php-composer(%{gh_owner}/zend-cache) >= 2.5
-BuildRequires: php-composer(phpunit/phpunit) >= 4.0
+# "zendframework/zend-cache": "^2.7",
+# "squizlabs/php_codesniffer": "^2.3.1",
+# "phpunit/PHPUnit": "^4.8"
+BuildRequires: php-composer(%{gh_owner}/zend-cache) >= 2.7
+BuildRequires: php-composer(phpunit/phpunit) >= 4.8
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": ">=5.3.23"
-Requires: php(language) >= 5.3.23
+# "php": "^5.5 || ^7.0"
+Requires: php(language) >= 5.5
%if ! %{bootstrap}
# From composer, "suggest": {
-# "zendframework/zend-cache": "To support swap the memory objects"
+# "zendframework/zend-cache": "To support swapping memory objects into and out of non-memory cache storage"
%if 0%{?fedora} >= 21
Suggests: php-composer(%{gh_owner}/zend-cache)
%endif
@@ -97,14 +97,14 @@ cp -pr src %{buildroot}%{php_home}/Zend/%{library}
%check
%if %{with_tests}
mkdir vendor
-cat << EOF | tee vendor/autoload.php
+cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{php_home}/Zend/Loader/AutoloaderFactory.php';
-Zend\\Loader\\AutoloaderFactory::factory(array(
- 'Zend\\Loader\\StandardAutoloader' => array(
+Zend\Loader\AutoloaderFactory::factory(array(
+ 'Zend\Loader\StandardAutoloader' => array(
'namespaces' => array(
- 'ZendTest\\\\%{library}' => dirname(__DIR__).'/test/',
- 'Zend\\\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
+ 'ZendTest\\%{library}' => dirname(__DIR__).'/test/',
+ 'Zend\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
))));
require_once '%{php_home}/Zend/autoload.php';
EOF
@@ -133,5 +133,9 @@ rm -rf %{buildroot}
%changelog
+* Wed May 11 2016 Remi Collet <remi@fedoraproject.org> - 2.5.2-1
+- update to 2.5.2
+- raise dependency on PHP >= 5.5
+
* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.1-1
-- initial package \ No newline at end of file
+- initial package