summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-memory.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zendframework-zend-memory.spec')
-rw-r--r--php-zendframework-zend-memory.spec38
1 files changed, 21 insertions, 17 deletions
diff --git a/php-zendframework-zend-memory.spec b/php-zendframework-zend-memory.spec
index 7189194..a845156 100644
--- a/php-zendframework-zend-memory.spec
+++ b/php-zendframework-zend-memory.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit ea25879c367ce2c13568640572fb79e882f5fc97
+%global gh_commit bbf8b9509660b2a97f2d6ccfefabffac3cca6a5c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-memory
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.5.1
+Version: 2.5.2
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -34,24 +34,24 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.3.23
+BuildRequires: php(language) >= 5.5
BuildRequires: php-spl
# From composer, "require-dev": {
-# "zendframework/zend-cache": "~2.5",
-# "fabpot/php-cs-fixer": "1.7.*",
-# "phpunit/PHPUnit": "~4.0"
-BuildRequires: php-composer(%{gh_owner}/zend-cache) >= 2.5
-BuildRequires: php-composer(phpunit/phpunit) >= 4.0
+# "zendframework/zend-cache": "^2.7",
+# "squizlabs/php_codesniffer": "^2.3.1",
+# "phpunit/PHPUnit": "^4.8"
+BuildRequires: php-composer(%{gh_owner}/zend-cache) >= 2.7
+BuildRequires: php-composer(phpunit/phpunit) >= 4.8
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": ">=5.3.23"
-Requires: php(language) >= 5.3.23
+# "php": "^5.5 || ^7.0"
+Requires: php(language) >= 5.5
%if ! %{bootstrap}
# From composer, "suggest": {
-# "zendframework/zend-cache": "To support swap the memory objects"
+# "zendframework/zend-cache": "To support swapping memory objects into and out of non-memory cache storage"
%if 0%{?fedora} >= 21
Suggests: php-composer(%{gh_owner}/zend-cache)
%endif
@@ -97,14 +97,14 @@ cp -pr src %{buildroot}%{php_home}/Zend/%{library}
%check
%if %{with_tests}
mkdir vendor
-cat << EOF | tee vendor/autoload.php
+cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{php_home}/Zend/Loader/AutoloaderFactory.php';
-Zend\\Loader\\AutoloaderFactory::factory(array(
- 'Zend\\Loader\\StandardAutoloader' => array(
+Zend\Loader\AutoloaderFactory::factory(array(
+ 'Zend\Loader\StandardAutoloader' => array(
'namespaces' => array(
- 'ZendTest\\\\%{library}' => dirname(__DIR__).'/test/',
- 'Zend\\\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
+ 'ZendTest\\%{library}' => dirname(__DIR__).'/test/',
+ 'Zend\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
))));
require_once '%{php_home}/Zend/autoload.php';
EOF
@@ -133,5 +133,9 @@ rm -rf %{buildroot}
%changelog
+* Wed May 11 2016 Remi Collet <remi@fedoraproject.org> - 2.5.2-1
+- update to 2.5.2
+- raise dependency on PHP >= 5.5
+
* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.1-1
-- initial package \ No newline at end of file
+- initial package