summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-11-08 08:44:33 +0100
committerRemi Collet <remi@remirepo.net>2017-11-08 08:44:33 +0100
commitf8eee68c71bac8246496586ae06a69385c23c6a6 (patch)
treef565ae97160034364d74a59e509fd142636caa70
parentcb9b9a582050824ff1cff10af12337f995cb9e6e (diff)
v2.7.5
-rw-r--r--150.patch4
-rw-r--r--php-zendframework-zend-inputfilter.spec9
2 files changed, 8 insertions, 5 deletions
diff --git a/150.patch b/150.patch
index 89eca38..4e1b4ca 100644
--- a/150.patch
+++ b/150.patch
@@ -11,12 +11,12 @@ diff --git a/src/CollectionInputFilter.php b/src/CollectionInputFilter.php
index 78a938a..da08386 100644
--- a/src/CollectionInputFilter.php
+++ b/src/CollectionInputFilter.php
-@@ -167,7 +167,7 @@ public function setData($data)
+@@ -167,7 +167,7 @@ class CollectionInputFilter extends Inpu
/**
* {@inheritdoc}
*/
- public function isValid()
+ public function isValid($context = null)
{
+ $this->collectionMessages = [];
$inputFilter = $this->getInputFilter();
- $valid = true;
diff --git a/php-zendframework-zend-inputfilter.spec b/php-zendframework-zend-inputfilter.spec
index 9b93cc6..59231f3 100644
--- a/php-zendframework-zend-inputfilter.spec
+++ b/php-zendframework-zend-inputfilter.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 699ab4916e0aa73104e1f9ff068ef6d33c5f5fe4
+%global gh_commit 02bbc6b5fc54991e43e7471e54e2173077708d7b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-inputfilter
@@ -20,8 +20,8 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.7.4
-Release: 3%{?dist}
+Version: 2.7.5
+Release: 1%{?dist}
Summary: Zend Framework %{library} component
Group: Development/Libraries
@@ -145,6 +145,9 @@ exit $ret
%changelog
+* Wed Nov 8 2017 Remi Collet <remi@remirepo.net> - 2.7.5-1
+- Update to 2.7.5
+
* Tue Oct 24 2017 Remi Collet <remi@remirepo.net> - 2.7.4-1
- fix FTBFS from Koschei, add patch for PHP 7.2 from
https://github.com/zendframework/zend-inputfilter/pull/150