summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-10-24 14:31:18 +0200
committerRemi Collet <remi@remirepo.net>2017-10-24 14:31:18 +0200
commitcb9b9a582050824ff1cff10af12337f995cb9e6e (patch)
tree3011f510d5e4efd329610725c0846c81130eefd7
parent6fe27fe4fe466db49d48c75ad8398a8e5adbe0a9 (diff)
fix FTBFS from Koschei, add patch for PHP 7.2 from https://github.com/zendframework/zend-inputfilter/pull/150
-rw-r--r--150.patch22
-rw-r--r--php-zendframework-zend-inputfilter.spec12
2 files changed, 31 insertions, 3 deletions
diff --git a/150.patch b/150.patch
new file mode 100644
index 0000000..89eca38
--- /dev/null
+++ b/150.patch
@@ -0,0 +1,22 @@
+From fd1e1cbd97acff453fb47327aa3128f93243a45d Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Tue, 24 Oct 2017 14:22:59 +0200
+Subject: [PATCH] fix proto for PHP 7.2
+
+---
+ src/CollectionInputFilter.php | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/CollectionInputFilter.php b/src/CollectionInputFilter.php
+index 78a938a..da08386 100644
+--- a/src/CollectionInputFilter.php
++++ b/src/CollectionInputFilter.php
+@@ -167,7 +167,7 @@ public function setData($data)
+ /**
+ * {@inheritdoc}
+ */
+- public function isValid()
++ public function isValid($context = null)
+ {
+ $inputFilter = $this->getInputFilter();
+ $valid = true;
diff --git a/php-zendframework-zend-inputfilter.spec b/php-zendframework-zend-inputfilter.spec
index 4b6f5df..9b93cc6 100644
--- a/php-zendframework-zend-inputfilter.spec
+++ b/php-zendframework-zend-inputfilter.spec
@@ -21,7 +21,7 @@
Name: php-%{gh_owner}-%{gh_project}
Version: 2.7.4
-Release: 1%{?dist}
+Release: 3%{?dist}
Summary: Zend Framework %{library} component
Group: Development/Libraries
@@ -30,6 +30,8 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
+Patch0: https://patch-diff.githubusercontent.com/raw/zendframework/zend-inputfilter/pull/150.patch
+
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -90,6 +92,7 @@ Documentation: https://zendframework.github.io/%{gh_project}/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+%patch0 -p1
mv LICENSE.md LICENSE
@@ -121,8 +124,7 @@ EOF
# https://github.com/zendframework/zend-inputfilter/pull/141
sed -e 's/PHPUnit_Framework_TestCase/PHPUnit\\Framework\\TestCase/' -i test/ConfigProviderTest.php
ret=0
-# PHP 7.2: https://github.com/zendframework/zend-inputfilter/issues/140
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71; do
+for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
@@ -143,6 +145,10 @@ exit $ret
%changelog
+* Tue Oct 24 2017 Remi Collet <remi@remirepo.net> - 2.7.4-1
+- fix FTBFS from Koschei, add patch for PHP 7.2 from
+ https://github.com/zendframework/zend-inputfilter/pull/150
+
* Mon May 22 2017 Remi Collet <remi@remirepo.net> - 2.7.4-1
- Update to 2.7.4
- raise dependency on PHP 5.6