summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-09-26 14:28:31 +0200
committerRemi Collet <remi@remirepo.net>2019-09-26 14:28:31 +0200
commitb83fd3836f5c491f37b55d23b91c6c9828272c91 (patch)
treefaca4b6099abb7ee1120540f02ab982f28afb569
parentce2e9e5e6c3bcba4e76fd84e1b053298172b49e3 (diff)
v2.9.1
-rw-r--r--114.patch22
-rw-r--r--composer.json2
-rw-r--r--php-zendframework-zend-i18n.spec21
3 files changed, 12 insertions, 33 deletions
diff --git a/114.patch b/114.patch
deleted file mode 100644
index 80daf16..0000000
--- a/114.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From 0a8cc92ce6dc1730404e255469082b085b55e84f Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Fri, 13 Sep 2019 14:45:45 +0200
-Subject: [PATCH] Fix Using array_key_exists() on objects is deprecated
-
----
- src/Translator/Loader/Gettext.php | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/Translator/Loader/Gettext.php b/src/Translator/Loader/Gettext.php
-index 2a23d5df..7bef31d2 100644
---- a/src/Translator/Loader/Gettext.php
-+++ b/src/Translator/Loader/Gettext.php
-@@ -139,7 +139,7 @@ public function load($locale, $filename)
- }
-
- // Read header entries
-- if (array_key_exists('', $textDomain)) {
-+ if (isset($textDomain[''])) {
- $rawHeaders = explode("\n", trim($textDomain['']));
-
- foreach ($rawHeaders as $rawHeader) {
diff --git a/composer.json b/composer.json
index 3235805..3597ff0 100644
--- a/composer.json
+++ b/composer.json
@@ -20,7 +20,7 @@
"zendframework/zend-stdlib": "^2.7 || ^3.0"
},
"require-dev": {
- "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2",
+ "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.16",
"zendframework/zend-cache": "^2.6.1",
"zendframework/zend-coding-standard": "~1.0.0",
"zendframework/zend-config": "^2.6",
diff --git a/php-zendframework-zend-i18n.spec b/php-zendframework-zend-i18n.spec
index a9f19b8..af5422c 100644
--- a/php-zendframework-zend-i18n.spec
+++ b/php-zendframework-zend-i18n.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-zendframework-zend-i18n
#
-# Copyright (c) 2015-2018 Remi Collet
+# Copyright (c) 2015-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 6d69af5a04e1a4de7250043cb1322f077a0cdb7f
+%global gh_commit 9233ee8553564a6e45e8311a7173734ba4e5db9b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-i18n
@@ -20,8 +20,8 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.9.0
-Release: 6%{?dist}
+Version: 2.9.1
+Release: 2%{?dist}
Summary: Zend Framework %{library} component
License: BSD
@@ -29,8 +29,6 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-Patch0: https://patch-diff.githubusercontent.com/raw/zendframework/zend-i18n/pull/114.patch
-
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -41,7 +39,7 @@ BuildRequires: php-intl
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer, "require-dev": {
-# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2",
+# "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.16",
# "zendframework/zend-cache": "^2.6.1",
# "zendframework/zend-coding-standard": "~1.0.0",
# "zendframework/zend-config": "^2.6",
@@ -61,7 +59,7 @@ BuildRequires: (php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5 with p
BuildRequires: (php-composer(%{gh_owner}/zend-validator) >= 2.6 with php-composer(%{gh_owner}/zend-validator) < 3)
BuildRequires: (php-composer(%{gh_owner}/zend-view) >= 2.6.3 with php-composer(%{gh_owner}/zend-view) < 3)
%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.1.2
+BuildRequires: phpunit7 >= 7.5.16
# remirepo:20
%else
BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
@@ -81,7 +79,7 @@ BuildRequires: php-composer(%{gh_owner}/zend-validator) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-view) < 3
BuildRequires: php-composer(%{gh_owner}/zend-view) >= 2.6.3
%global phpunit %{_bindir}/phpunit6
-BuildRequires: phpunit6 >= 6.5.8
+BuildRequires: phpunit6 >= 6.5.14
%endif
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
@@ -151,7 +149,6 @@ Documentation: https://zendframework.github.io/%{gh_project}/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
mv LICENSE.md LICENSE
@@ -220,6 +217,10 @@ exit $ret
%changelog
+* Thu Sep 26 2019 Remi Collet <remi@remirepo.net> - 2.9.1-2
+- update to 2.9.1
+- drop patch merged upstream
+
* Fri Sep 13 2019 Remi Collet <remi@remirepo.net> - 2.9.0-6
- add patch for 7.4 from
https://github.com/zendframework/zend-i18n/pull/114