summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-09-13 15:27:05 +0200
committerRemi Collet <remi@remirepo.net>2019-09-13 15:27:05 +0200
commitce2e9e5e6c3bcba4e76fd84e1b053298172b49e3 (patch)
tree6af06fa8a2e3b289c5110c22996748be691fbe9f
parentc4c160af7c8cf026c121120dc6db522816607dfd (diff)
add patch for 7.4 from
https://github.com/zendframework/zend-i18n/pull/114
-rw-r--r--114.patch22
-rw-r--r--php-zendframework-zend-i18n.spec13
2 files changed, 32 insertions, 3 deletions
diff --git a/114.patch b/114.patch
new file mode 100644
index 0000000..80daf16
--- /dev/null
+++ b/114.patch
@@ -0,0 +1,22 @@
+From 0a8cc92ce6dc1730404e255469082b085b55e84f Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Fri, 13 Sep 2019 14:45:45 +0200
+Subject: [PATCH] Fix Using array_key_exists() on objects is deprecated
+
+---
+ src/Translator/Loader/Gettext.php | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/Translator/Loader/Gettext.php b/src/Translator/Loader/Gettext.php
+index 2a23d5df..7bef31d2 100644
+--- a/src/Translator/Loader/Gettext.php
++++ b/src/Translator/Loader/Gettext.php
+@@ -139,7 +139,7 @@ public function load($locale, $filename)
+ }
+
+ // Read header entries
+- if (array_key_exists('', $textDomain)) {
++ if (isset($textDomain[''])) {
+ $rawHeaders = explode("\n", trim($textDomain['']));
+
+ foreach ($rawHeaders as $rawHeader) {
diff --git a/php-zendframework-zend-i18n.spec b/php-zendframework-zend-i18n.spec
index b38cb28..a9f19b8 100644
--- a/php-zendframework-zend-i18n.spec
+++ b/php-zendframework-zend-i18n.spec
@@ -21,7 +21,7 @@
Name: php-%{gh_owner}-%{gh_project}
Version: 2.9.0
-Release: 2%{?dist}
+Release: 6%{?dist}
Summary: Zend Framework %{library} component
License: BSD
@@ -29,6 +29,8 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
+Patch0: https://patch-diff.githubusercontent.com/raw/zendframework/zend-i18n/pull/114.patch
+
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -149,6 +151,7 @@ Documentation: https://zendframework.github.io/%{gh_project}/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+%patch0 -p1
mv LICENSE.md LICENSE
@@ -192,11 +195,11 @@ require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php70 %{_bindir}/phpunit6" php71 php72; do
+for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit7} \
-%if 0%{?fedora} >= 29
+%if 0%{?fedora} >= 29 || 0%{?rhel} >= 8
--filter '^((?!(testSettersProvideDefaults|testBasic)).)*$' \
%endif
--verbose || ret=1
@@ -217,6 +220,10 @@ exit $ret
%changelog
+* Fri Sep 13 2019 Remi Collet <remi@remirepo.net> - 2.9.0-6
+- add patch for 7.4 from
+ https://github.com/zendframework/zend-i18n/pull/114
+
* Wed May 23 2018 Remi Collet <remi@remirepo.net> - 2.9.0-2
- update to 2.9.0
- skip test failing with libicu 61, reported as