summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-07-01 20:05:25 +0200
committerRemi Collet <fedora@famillecollet.com>2016-07-01 20:05:25 +0200
commita786a84a0f2dc6e236b70e44b952aa4785edb685 (patch)
treea389fb9c334a4d56bea61180b0a8153581062b52
parent0d1c42b482e5435cca93d920cd2e23808eb952a9 (diff)
php-zendframework-zend-expressive-zendrouter: 1.1.0 (New Package)
-rw-r--r--php-zendframework-zend-expressive-fastroute.spec8
1 files changed, 6 insertions, 2 deletions
diff --git a/php-zendframework-zend-expressive-fastroute.spec b/php-zendframework-zend-expressive-fastroute.spec
index 85bc454..be8f638 100644
--- a/php-zendframework-zend-expressive-fastroute.spec
+++ b/php-zendframework-zend-expressive-fastroute.spec
@@ -46,6 +46,8 @@ BuildRequires: php-pcre
BuildRequires: php-composer(phpunit/phpunit) >= 4.7
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
+# For dependencies autoloader
+BuildRequires: php-zendframework-zend-loader >= 2.5.1-3
%endif
# From composer, "require": {
@@ -74,7 +76,8 @@ Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
%description
Provides FastRoute integration for Expressive.
-Documentation: http://zend-expressive.readthedocs.io/
+Documentation:
+https://zendframework.github.io/zend-expressive/features/router/fast-route/
%prep
@@ -82,10 +85,11 @@ Documentation: http://zend-expressive.readthedocs.io/
mv LICENSE.md LICENSE
+# psr/http-message load by zend-expressive-router
+
: Create dependency autoloader
cat << 'EOF' | tee autoload.php
<?php
-require_once '%{php_home}/Psr/Http/Message/autoload.php';
require_once '%{php_home}/FastRoute/bootstrap.php';
EOF