summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-expressive-fastroute.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zendframework-zend-expressive-fastroute.spec')
-rw-r--r--php-zendframework-zend-expressive-fastroute.spec8
1 files changed, 6 insertions, 2 deletions
diff --git a/php-zendframework-zend-expressive-fastroute.spec b/php-zendframework-zend-expressive-fastroute.spec
index 85bc454..be8f638 100644
--- a/php-zendframework-zend-expressive-fastroute.spec
+++ b/php-zendframework-zend-expressive-fastroute.spec
@@ -46,6 +46,8 @@ BuildRequires: php-pcre
BuildRequires: php-composer(phpunit/phpunit) >= 4.7
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
+# For dependencies autoloader
+BuildRequires: php-zendframework-zend-loader >= 2.5.1-3
%endif
# From composer, "require": {
@@ -74,7 +76,8 @@ Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
%description
Provides FastRoute integration for Expressive.
-Documentation: http://zend-expressive.readthedocs.io/
+Documentation:
+https://zendframework.github.io/zend-expressive/features/router/fast-route/
%prep
@@ -82,10 +85,11 @@ Documentation: http://zend-expressive.readthedocs.io/
mv LICENSE.md LICENSE
+# psr/http-message load by zend-expressive-router
+
: Create dependency autoloader
cat << 'EOF' | tee autoload.php
<?php
-require_once '%{php_home}/Psr/Http/Message/autoload.php';
require_once '%{php_home}/FastRoute/bootstrap.php';
EOF