summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-11-02 06:47:13 +0100
committerRemi Collet <remi@remirepo.net>2017-11-02 06:47:13 +0100
commit17cd3ba369e7349f176d658398f8a801934f8904 (patch)
tree273c70ad4ab46e22d7d5c252937e843b723855cd
parentccd38fea91bf6124a0b70a68d963b165baadb14f (diff)
v1.6.1
-rw-r--r--.gitignore14
-rw-r--r--composer.json17
-rw-r--r--php-zendframework-zend-diactoros.spec23
3 files changed, 33 insertions, 21 deletions
diff --git a/.gitignore b/.gitignore
index e8c0751..fc9aa8c 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,8 +1,8 @@
clog
-/php-zendframework-zend-diactoros-1.1.2-eeedadd333b80bb5d93559e2285047463fe4fe33.tar.gz
-/php-zendframework-zend-diactoros-1.1.3-e2f5c12916c74da384058d0dfbc7fbc0b03d1181.tar.gz
-/php-zendframework-zend-diactoros-1.1.4-3f0ce6c0ba2106e018fb514a9f09dbb91eb6bfd0.tar.gz
-/php-zendframework-zend-diactoros-1.3.3-4d54fde709664562eb63356f0250d527824d05de.tar.gz
-/php-zendframework-zend-diactoros-1.3.7-969ff423d3f201da3ff718a5831bb999bb0669b0.tar.gz
-/php-zendframework-zend-diactoros-1.3.10-83e8d98b9915de76c659ce27d683c02a0f99fa90.tar.gz
-/php-zendframework-zend-diactoros-1.4.0-b03f285a333f51e58c95cce54109a4a9ed691436.tar.gz
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/composer.json b/composer.json
index 12e4a9f..feb9aec 100644
--- a/composer.json
+++ b/composer.json
@@ -13,21 +13,24 @@
"issues": "https://github.com/zendframework/zend-diactoros/issues",
"source": "https://github.com/zendframework/zend-diactoros"
},
+ "config": {
+ "sort-packages": true
+ },
"extra": {
"branch-alias": {
- "dev-master": "1.4-dev",
- "dev-develop": "1.5-dev"
+ "dev-master": "1.6-dev",
+ "dev-develop": "1.7-dev"
}
},
"require": {
- "php": "^5.4 || ^7.0",
- "psr/http-message": "~1.0"
+ "php": "^5.6 || ^7.0",
+ "psr/http-message": "^1.0"
},
"require-dev": {
- "phpunit/phpunit": "^4.6 || ^5.5",
- "zendframework/zend-coding-standard": "~1.0.0",
"ext-dom": "*",
- "ext-libxml": "*"
+ "ext-libxml": "*",
+ "phpunit/phpunit": "^5.7.16 || ^6.0.8",
+ "zendframework/zend-coding-standard": "~1.0"
},
"provide": {
"psr/http-message-implementation": "1.0"
diff --git a/php-zendframework-zend-diactoros.spec b/php-zendframework-zend-diactoros.spec
index 4e4ba52..28dcf1f 100644
--- a/php-zendframework-zend-diactoros.spec
+++ b/php-zendframework-zend-diactoros.spec
@@ -12,8 +12,8 @@
%global github_owner zendframework
%global github_name zend-diactoros
-%global github_version 1.6.0
-%global github_commit 2faa791b66bac33ca40031d8bce03b7dc8143490
+%global github_version 1.6.1
+%global github_commit c8664b92a6d5bc229e48b0923486c097e45a7877
%global composer_vendor zendframework
%global composer_project zend-diactoros
@@ -48,7 +48,12 @@ BuildArch: noarch
%if %{with_tests}
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
-BuildRequires: php-composer(phpunit/phpunit)
+%if 0%{?fedora} >= 26
+%global phpunit %{_bindir}/phpunit6
+%else
+%global phpunit %{_bindir}/phpunit
+%endif
+BuildRequires: %{phpunit}
BuildRequires: php-composer(psr/http-message) < %{psr_http_message_max_ver}
BuildRequires: php-composer(psr/http-message) >= %{psr_http_message_min_ver}
BuildRequires: php-dom
@@ -145,10 +150,10 @@ sed 's/function testReasonPhraseDefaultsAgainstIana/function SKIP_testReasonPhra
: Upstream tests
RETURN_CODE=0
-PHPUNIT=$(which phpunit)
-for PHP_EXEC in "" %{?rhel:php55} php56 php70 php71 php72; do
- if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
- $PHP_EXEC $PHPUNIT --bootstrap bootstrap.php --verbose \
+for CMDARG in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+ if which $CMDARG; then
+ set $CMDARG
+ $1 ${2:-%{_bindir}/phpunit6} --bootstrap bootstrap.php --verbose \
|| RETURN_CODE=1
fi
done
@@ -168,6 +173,10 @@ exit $RETURN_CODE
%changelog
+* Thu Nov 2 2017 Remi Collet <remi@remirepo.net> - 1.6.1-1
+- Update to 1.6.1
+- use phpunit6 on F26+
+
* Sun Oct 08 2017 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.6.0-1
- Updated to 1.6.0 (RHBZ #1491486)