summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-diactoros.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zendframework-zend-diactoros.spec')
-rw-r--r--php-zendframework-zend-diactoros.spec23
1 files changed, 16 insertions, 7 deletions
diff --git a/php-zendframework-zend-diactoros.spec b/php-zendframework-zend-diactoros.spec
index 4e4ba52..28dcf1f 100644
--- a/php-zendframework-zend-diactoros.spec
+++ b/php-zendframework-zend-diactoros.spec
@@ -12,8 +12,8 @@
%global github_owner zendframework
%global github_name zend-diactoros
-%global github_version 1.6.0
-%global github_commit 2faa791b66bac33ca40031d8bce03b7dc8143490
+%global github_version 1.6.1
+%global github_commit c8664b92a6d5bc229e48b0923486c097e45a7877
%global composer_vendor zendframework
%global composer_project zend-diactoros
@@ -48,7 +48,12 @@ BuildArch: noarch
%if %{with_tests}
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
-BuildRequires: php-composer(phpunit/phpunit)
+%if 0%{?fedora} >= 26
+%global phpunit %{_bindir}/phpunit6
+%else
+%global phpunit %{_bindir}/phpunit
+%endif
+BuildRequires: %{phpunit}
BuildRequires: php-composer(psr/http-message) < %{psr_http_message_max_ver}
BuildRequires: php-composer(psr/http-message) >= %{psr_http_message_min_ver}
BuildRequires: php-dom
@@ -145,10 +150,10 @@ sed 's/function testReasonPhraseDefaultsAgainstIana/function SKIP_testReasonPhra
: Upstream tests
RETURN_CODE=0
-PHPUNIT=$(which phpunit)
-for PHP_EXEC in "" %{?rhel:php55} php56 php70 php71 php72; do
- if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
- $PHP_EXEC $PHPUNIT --bootstrap bootstrap.php --verbose \
+for CMDARG in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+ if which $CMDARG; then
+ set $CMDARG
+ $1 ${2:-%{_bindir}/phpunit6} --bootstrap bootstrap.php --verbose \
|| RETURN_CODE=1
fi
done
@@ -168,6 +173,10 @@ exit $RETURN_CODE
%changelog
+* Thu Nov 2 2017 Remi Collet <remi@remirepo.net> - 1.6.1-1
+- Update to 1.6.1
+- use phpunit6 on F26+
+
* Sun Oct 08 2017 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.6.0-1
- Updated to 1.6.0 (RHBZ #1491486)