summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-crypt.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-06-28 07:32:34 +0200
committerRemi Collet <fedora@famillecollet.com>2016-06-28 07:32:34 +0200
commitb4512ce3d4d390a846010ef185019054e834ef21 (patch)
treeea4fb9fa07de22fd5417a8837ed42f4e7f0d0bf2 /php-zendframework-zend-crypt.spec
parent33f64474bf46318425c8506455800efd9a9f8f25 (diff)
php-zendframework-zend-crypt: improve %check
Diffstat (limited to 'php-zendframework-zend-crypt.spec')
-rw-r--r--php-zendframework-zend-crypt.spec15
1 files changed, 11 insertions, 4 deletions
diff --git a/php-zendframework-zend-crypt.spec b/php-zendframework-zend-crypt.spec
index d73343d..e57ecf7 100644
--- a/php-zendframework-zend-crypt.spec
+++ b/php-zendframework-zend-crypt.spec
@@ -130,11 +130,18 @@ Zend\Loader\AutoloaderFactory::factory(array(
require_once '%{php_home}/Zend/autoload.php';
EOF
-%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
-
-if which php70; then
- php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
+run=0
+ret=0
+if which php56; then
+ php56 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} --verbose || ret=1
+fi
+if which php71; then
+ php71 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} --verbose || ret=1
+fi
+if [ $run -eq 0 ]; then
+ %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} --verbose || ret=1
fi
+exit $ret
%else
: Test suite disabled
%endif