summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-zendframework-zend-crypt.spec15
1 files changed, 11 insertions, 4 deletions
diff --git a/php-zendframework-zend-crypt.spec b/php-zendframework-zend-crypt.spec
index d73343d..e57ecf7 100644
--- a/php-zendframework-zend-crypt.spec
+++ b/php-zendframework-zend-crypt.spec
@@ -130,11 +130,18 @@ Zend\Loader\AutoloaderFactory::factory(array(
require_once '%{php_home}/Zend/autoload.php';
EOF
-%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
-
-if which php70; then
- php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
+run=0
+ret=0
+if which php56; then
+ php56 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} --verbose || ret=1
+fi
+if which php71; then
+ php71 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} --verbose || ret=1
+fi
+if [ $run -eq 0 ]; then
+ %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} --verbose || ret=1
fi
+exit $ret
%else
: Test suite disabled
%endif