summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-barcode.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zendframework-zend-barcode.spec')
-rw-r--r--php-zendframework-zend-barcode.spec21
1 files changed, 16 insertions, 5 deletions
diff --git a/php-zendframework-zend-barcode.spec b/php-zendframework-zend-barcode.spec
index 80a9d43..afdf574 100644
--- a/php-zendframework-zend-barcode.spec
+++ b/php-zendframework-zend-barcode.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-zendframework-zend-barcode
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 50f24f604ef2172a0127efe91e786bc2caf2e8cf
+%global gh_commit 6db95687997920b8217e71d2f12b51ec10e824d9
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-barcode
@@ -20,16 +20,17 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.7.0
+Version: 2.8.0
Release: 1%{?dist}
Summary: Zend Framework %{library} component
-Group: Development/Libraries
License: BSD
URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
+Patch0: https://patch-diff.githubusercontent.com/raw/laminas/laminas-barcode/pull/2.patch
+
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -110,6 +111,8 @@ Documentation: https://zendframework.github.io/%{gh_project}/
mv LICENSE.md LICENSE
+%patch0 -p1 -b .pr2
+
%build
phpab --template fedora --output src/autoload.php src
@@ -144,7 +147,7 @@ EOF
export TESTS_ZEND_BARCODE_PDF_SUPPORT=1
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
@@ -165,6 +168,14 @@ exit $ret
%changelog
+* Thu Jan 2 2020 Remi Collet <remi@remirepo.net> - 2.8.0-1
+- update to 2.8.0
+- add patch for PHP 7.4 from
+ https://github.com/laminas/laminas-barcode/pull/2
+
+* Mon Sep 23 2019 Remi Collet <remi@remirepo.net> - 2.7.1-1
+- update to 2.7.1
+
* Tue Dec 12 2017 Remi Collet <remi@remirepo.net> - 2.7.0-1
- Update to 2.7.0
- raise dependency on PHP 5.6