summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--2.patch35
-rw-r--r--composer.json11
-rw-r--r--php-zendframework-zend-barcode.spec21
3 files changed, 56 insertions, 11 deletions
diff --git a/2.patch b/2.patch
new file mode 100644
index 0000000..608ef25
--- /dev/null
+++ b/2.patch
@@ -0,0 +1,35 @@
+From c765b77757f5fff04998232fd45d401b48288102 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Thu, 2 Jan 2020 14:34:04 +0100
+Subject: [PATCH] Fix Invalid characters passed for attempted conversion (7.4)
+
+---
+ src/Object/AbstractObject.php | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/src/Object/AbstractObject.php b/src/Object/AbstractObject.php
+index a3b2d48..0fa2689 100644
+--- a/src/Object/AbstractObject.php
++++ b/src/Object/AbstractObject.php
+@@ -429,8 +429,8 @@ public function getFactor()
+ */
+ public function setForeColor($value)
+ {
+- if (preg_match('`\#[0-9A-F]{6}`', $value)) {
+- $this->foreColor = hexdec($value);
++ if (preg_match('`\#([0-9A-F]{6})`', $value, $reg)) {
++ $this->foreColor = hexdec($reg[1]);
+ } elseif (is_numeric($value) && $value >= 0 && $value <= 16777125) {
+ $this->foreColor = intval($value);
+ } else {
+@@ -460,8 +460,8 @@ public function getForeColor()
+ */
+ public function setBackgroundColor($value)
+ {
+- if (preg_match('`\#[0-9A-F]{6}`', $value)) {
+- $this->backgroundColor = hexdec($value);
++ if (preg_match('`\#([0-9A-F]{6})`', $value, $reg)) {
++ $this->backgroundColor = hexdec($reg[1]);
+ } elseif (is_numeric($value) && $value >= 0 && $value <= 16777125) {
+ $this->backgroundColor = intval($value);
+ } else {
diff --git a/composer.json b/composer.json
index 8fd1b34..f9696bf 100644
--- a/composer.json
+++ b/composer.json
@@ -1,6 +1,6 @@
{
"name": "zendframework/zend-barcode",
- "description": "provides a generic way to generate barcodes",
+ "description": "Programmatically create and render barcodes as images or in PDFs",
"license": "BSD-3-Clause",
"keywords": [
"zf",
@@ -12,7 +12,7 @@
"issues": "https://github.com/zendframework/zend-barcode/issues",
"source": "https://github.com/zendframework/zend-barcode",
"rss": "https://github.com/zendframework/zend-barcode/releases.atom",
- "slack": "https://zendframework-slack.herokuapp.com",
+ "chat": "https://zendframework-slack.herokuapp.com",
"forum": "https://discourse.zendframework.com/c/questions/components"
},
"require": {
@@ -45,8 +45,8 @@
},
"extra": {
"branch-alias": {
- "dev-master": "2.7.x-dev",
- "dev-develop": "2.8.x-dev"
+ "dev-master": "2.8.x-dev",
+ "dev-develop": "2.9.x-dev"
}
},
"scripts": {
@@ -57,7 +57,6 @@
"cs-check": "phpcs",
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
- "test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
- "upload-coverage": "coveralls -v"
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
}
}
diff --git a/php-zendframework-zend-barcode.spec b/php-zendframework-zend-barcode.spec
index 80a9d43..afdf574 100644
--- a/php-zendframework-zend-barcode.spec
+++ b/php-zendframework-zend-barcode.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-zendframework-zend-barcode
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 50f24f604ef2172a0127efe91e786bc2caf2e8cf
+%global gh_commit 6db95687997920b8217e71d2f12b51ec10e824d9
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-barcode
@@ -20,16 +20,17 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.7.0
+Version: 2.8.0
Release: 1%{?dist}
Summary: Zend Framework %{library} component
-Group: Development/Libraries
License: BSD
URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
+Patch0: https://patch-diff.githubusercontent.com/raw/laminas/laminas-barcode/pull/2.patch
+
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -110,6 +111,8 @@ Documentation: https://zendframework.github.io/%{gh_project}/
mv LICENSE.md LICENSE
+%patch0 -p1 -b .pr2
+
%build
phpab --template fedora --output src/autoload.php src
@@ -144,7 +147,7 @@ EOF
export TESTS_ZEND_BARCODE_PDF_SUPPORT=1
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
@@ -165,6 +168,14 @@ exit $ret
%changelog
+* Thu Jan 2 2020 Remi Collet <remi@remirepo.net> - 2.8.0-1
+- update to 2.8.0
+- add patch for PHP 7.4 from
+ https://github.com/laminas/laminas-barcode/pull/2
+
+* Mon Sep 23 2019 Remi Collet <remi@remirepo.net> - 2.7.1-1
+- update to 2.7.1
+
* Tue Dec 12 2017 Remi Collet <remi@remirepo.net> - 2.7.0-1
- Update to 2.7.0
- raise dependency on PHP 5.6