summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-03-31 09:19:56 +0200
committerRemi Collet <remi@php.net>2023-03-31 09:19:56 +0200
commit7b13e26617654e306134e88882c244a1ac0a9ce3 (patch)
treeab6491a00d567400137c843450849a96102fe3ff
parent53dc940387fbc3740688656c288f5ce7af608ccf (diff)
update to 1.0.5
-rw-r--r--composer.json5
-rw-r--r--php-yoast-phpunit-polyfills.spec46
2 files changed, 16 insertions, 35 deletions
diff --git a/composer.json b/composer.json
index 1ce3c03..2af26d8 100644
--- a/composer.json
+++ b/composer.json
@@ -27,7 +27,7 @@
"phpunit/phpunit": "^4.8.36 || ^5.7.21 || ^6.0 || ^7.0 || ^8.0 || ^9.0"
},
"require-dev": {
- "yoast/yoastcs": "^2.2.1"
+ "yoast/yoastcs": "^2.3.0"
},
"config": {
"allow-plugins": {
@@ -44,8 +44,7 @@
},
"extra": {
"branch-alias": {
- "dev-main": "1.x-dev",
- "dev-develop": "1.x-dev"
+ "dev-main": "2.x-dev"
}
},
"scripts": {
diff --git a/php-yoast-phpunit-polyfills.spec b/php-yoast-phpunit-polyfills.spec
index 5266904..a13f7dd 100644
--- a/php-yoast-phpunit-polyfills.spec
+++ b/php-yoast-phpunit-polyfills.spec
@@ -1,13 +1,13 @@
# remirepo/fedora spec file for php-yoast-phpunit-polyfills
#
-# Copyright (c) 2020-2022 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2020-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please preserve changelog entries
#
# Github
-%global gh_commit 3c621ff5429d2b1ff96dc5808ad6cde99d31ea4c
+%global gh_commit 3b59adeef77fb1c03ff5381dbb9d68b0aaff3171
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner Yoast
%global gh_project PHPUnit-Polyfills
@@ -23,11 +23,11 @@
%global php_home %{_datadir}/php
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 1.0.4
+Version: 1.0.5
Release: 1%{?dist}
Summary: Set of polyfills for changed PHPUnit functionality
-License: BSD
+License: BSD-3-Clause
URL: https://github.com/%{gh_owner}/%{gh_project}
# git snapshot to get upstream test suite
Source0: %{name}-%{version}-%{gh_short}.tgz
@@ -38,17 +38,11 @@ BuildArch: noarch
BuildRequires: php(language) >= 5.4
BuildRequires: php-reflection
# From composer.json, "require-dev": {
-# "yoast/yoastcs": "^2.2.0"
-%if 0%{?fedora} >= 32 || 0%{?rhel} >= 9
+# "yoast/yoastcs": "^2.3.0"
BuildRequires: phpunit9
-%endif
BuildRequires: phpunit8
-%if 0%{?fedora} < 35 && 0%{?rhel} < 9
-BuildRequires: phpunit7
-BuildRequires: phpunit
%endif
BuildRequires: php-fedora-autoloader-devel
-%endif
# From composer.json, "require": {
# "php": ">=5.4",
@@ -98,37 +92,22 @@ EOF
: Run upstream test suite
ret=0
if [ -x %{_bindir}/phpunit ]; then
- for cmd in php php71 php72 php73 php74; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit --no-coverage --verbose || ret=1
- fi
- done
-fi
-if [ -x %{_bindir}/phpunit6 ]; then
- for cmd in php php71 php72 php73 php74; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit6 --no-coverage --verbose || ret=1
- fi
- done
+ %{_bindir}/phpunit --no-coverage || ret=1
fi
if [ -x %{_bindir}/phpunit7 ]; then
- for cmd in php php71 php72 php73 php74; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit7 --no-coverage --verbose || ret=1
- fi
- done
+ %{_bindir}/phpunit7 --no-coverage || ret=1
fi
if [ -x %{_bindir}/phpunit8 ]; then
- for cmd in php php72 php73 php74 php80 php81; do
+ for cmd in php php80 php81 php82; do
if which $cmd; then
- $cmd %{_bindir}/phpunit8 --no-coverage --verbose || ret=1
+ $cmd %{_bindir}/phpunit8 --no-coverage || ret=1
fi
done
fi
if [ -x %{_bindir}/phpunit9 ]; then
for cmd in php php80 php81 php82; do
if which $cmd; then
- $cmd %{_bindir}/phpunit9 --no-coverage --verbose || ret=1
+ $cmd %{_bindir}/phpunit9 --no-coverage || ret=1
fi
done
fi
@@ -147,6 +126,9 @@ exit $ret
%changelog
+* Fri Mar 31 2023 Remi Collet <remi@remirepo.net> - 1.0.5-1
+- update to 1.0.5
+
* Wed Nov 16 2022 Remi Collet <remi@remirepo.net> - 1.0.4-1
- update to 1.0.4