summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-11-16 14:21:30 +0100
committerRemi Collet <remi@php.net>2022-11-16 14:21:30 +0100
commit53dc940387fbc3740688656c288f5ce7af608ccf (patch)
treebbc30e7e2a034701eb6128fbd5f7973149b14422
parent173b82a8e4ad09d43547b4c482560626b99ad575 (diff)
update to 1.0.4
-rw-r--r--composer.json13
-rw-r--r--php-yoast-phpunit-polyfills.spec11
2 files changed, 16 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index aec37f5..1ce3c03 100644
--- a/composer.json
+++ b/composer.json
@@ -27,7 +27,12 @@
"phpunit/phpunit": "^4.8.36 || ^5.7.21 || ^6.0 || ^7.0 || ^8.0 || ^9.0"
},
"require-dev": {
- "yoast/yoastcs": "^2.2.0"
+ "yoast/yoastcs": "^2.2.1"
+ },
+ "config": {
+ "allow-plugins": {
+ "dealerdirect/phpcodesniffer-composer-installer": true
+ }
},
"autoload": {
"files": ["phpunitpolyfills-autoload.php"]
@@ -45,13 +50,13 @@
},
"scripts": {
"lint7": [
- "@php ./vendor/php-parallel-lint/php-parallel-lint/parallel-lint . -e php --exclude vendor --exclude .git --exclude src/Exceptions/Error.php --exclude src/Exceptions/TypeError.php --exclude tests/Polyfills/Fixtures/ValueObjectUnion.php --exclude tests/Polyfills/Fixtures/ValueObjectUnionNoReturnType.php"
+ "@php ./vendor/php-parallel-lint/php-parallel-lint/parallel-lint . -e php --show-deprecated --exclude vendor --exclude .git --exclude src/Exceptions/Error.php --exclude src/Exceptions/TypeError.php --exclude tests/Polyfills/Fixtures/ValueObjectUnion.php --exclude tests/Polyfills/Fixtures/ValueObjectUnionNoReturnType.php"
],
"lint-lt70": [
- "@php ./vendor/php-parallel-lint/php-parallel-lint/parallel-lint . -e php --exclude vendor --exclude .git --exclude src/TestCases/TestCasePHPUnitGte8.php --exclude src/TestListeners/TestListenerDefaultImplementationPHPUnitGte7.php --exclude tests/Polyfills/Fixtures/ChildValueObject.php --exclude tests/Polyfills/Fixtures/ValueObject.php --exclude tests/Polyfills/Fixtures/ValueObjectUnion.php --exclude tests/Polyfills/Fixtures/ValueObjectUnionNoReturnType.php"
+ "@php ./vendor/php-parallel-lint/php-parallel-lint/parallel-lint . -e php --show-deprecated --exclude vendor --exclude .git --exclude src/TestCases/TestCasePHPUnitGte8.php --exclude src/TestListeners/TestListenerDefaultImplementationPHPUnitGte7.php --exclude tests/Polyfills/Fixtures/ChildValueObject.php --exclude tests/Polyfills/Fixtures/ValueObject.php --exclude tests/Polyfills/Fixtures/ValueObjectUnion.php --exclude tests/Polyfills/Fixtures/ValueObjectUnionNoReturnType.php"
],
"lint-gte80": [
- "@php ./vendor/php-parallel-lint/php-parallel-lint/parallel-lint . -e php --exclude vendor --exclude .git"
+ "@php ./vendor/php-parallel-lint/php-parallel-lint/parallel-lint . -e php --show-deprecated --exclude vendor --exclude .git"
],
"check-cs": [
"@php ./vendor/squizlabs/php_codesniffer/bin/phpcs --runtime-set testVersion 5.4-"
diff --git a/php-yoast-phpunit-polyfills.spec b/php-yoast-phpunit-polyfills.spec
index 01f5852..5266904 100644
--- a/php-yoast-phpunit-polyfills.spec
+++ b/php-yoast-phpunit-polyfills.spec
@@ -1,13 +1,13 @@
# remirepo/fedora spec file for php-yoast-phpunit-polyfills
#
-# Copyright (c) 2020 Remi Collet
+# Copyright (c) 2020-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please preserve changelog entries
#
# Github
-%global gh_commit 5ea3536428944955f969bc764bbe09738e151ada
+%global gh_commit 3c621ff5429d2b1ff96dc5808ad6cde99d31ea4c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner Yoast
%global gh_project PHPUnit-Polyfills
@@ -23,7 +23,7 @@
%global php_home %{_datadir}/php
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 1.0.3
+Version: 1.0.4
Release: 1%{?dist}
Summary: Set of polyfills for changed PHPUnit functionality
@@ -126,7 +126,7 @@ if [ -x %{_bindir}/phpunit8 ]; then
done
fi
if [ -x %{_bindir}/phpunit9 ]; then
- for cmd in php php73 php74 php80 php81; do
+ for cmd in php php80 php81 php82; do
if which $cmd; then
$cmd %{_bindir}/phpunit9 --no-coverage --verbose || ret=1
fi
@@ -147,6 +147,9 @@ exit $ret
%changelog
+* Wed Nov 16 2022 Remi Collet <remi@remirepo.net> - 1.0.4-1
+- update to 1.0.4
+
* Tue Nov 23 2021 Remi Collet <remi@remirepo.net> - 1.0.3-1
- update to 1.0.3