summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-03-17 15:02:20 +0100
committerRemi Collet <remi@remirepo.net>2020-03-17 15:02:20 +0100
commitb937d2c18d477fc5490181057949a5819be259f5 (patch)
tree2a6a9e5880eaa5ce5b07aff252f03c142d2b2d71
parent37ef656afa1337ce7439c9a57863c554c537728f (diff)
add backport stuff
-rw-r--r--Makefile4
l---------makesrc.sh1
-rwxr-xr-xphp-webimpress-safe-writer-get-source.sh1
-rw-r--r--php-webimpress-safe-writer.spec3
4 files changed, 8 insertions, 1 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/makesrc.sh b/makesrc.sh
new file mode 120000
index 0000000..ea46acb
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1 @@
+php-webimpress-safe-writer-get-source.sh \ No newline at end of file
diff --git a/php-webimpress-safe-writer-get-source.sh b/php-webimpress-safe-writer-get-source.sh
index b2ac62b..4a51e05 100755
--- a/php-webimpress-safe-writer-get-source.sh
+++ b/php-webimpress-safe-writer-get-source.sh
@@ -55,6 +55,7 @@ pushd $TEMP_DIR
pushd $GIT_DIR
print "Checking out commit..."
$GIT checkout $GIT_COMMIT
+ cp composer.json ${SPEC_DIR}/composer.json
popd
TAR_DIR=${GIT_NAME}-${GIT_COMMIT}
diff --git a/php-webimpress-safe-writer.spec b/php-webimpress-safe-writer.spec
index 3f2e70d..3b524a9 100644
--- a/php-webimpress-safe-writer.spec
+++ b/php-webimpress-safe-writer.spec
@@ -1,3 +1,4 @@
+# remirepo spec file for php-webimpress-safe-writer, from:
#
# Fedora spec file for php-webimpress-safe-writer
#
@@ -102,7 +103,7 @@ sed 's/function testMultipleWriters/function SKIP_testMultipleWriters/' \
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which phpunit8)
-for PHP_EXEC in php php70 php71 php72 php73 php74; do
+for PHP_EXEC in php php72 php73 php74; do
if [ "php" == "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose \
--bootstrap %{buildroot}%{phpdir}/Webimpress/SafeWriter/autoload.php \