summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-03-17 14:59:05 +0100
committerRemi Collet <remi@remirepo.net>2020-03-17 14:59:05 +0100
commit37ef656afa1337ce7439c9a57863c554c537728f (patch)
treeceb985468e0553045d3502f4e5a8087cc9f30ba9
import from Fedora
-rw-r--r--composer.json49
-rwxr-xr-xphp-webimpress-safe-writer-get-source.sh73
-rw-r--r--php-webimpress-safe-writer.spec129
3 files changed, 251 insertions, 0 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..79cfbf1
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,49 @@
+{
+ "name": "webimpress/safe-writer",
+ "description": "Tool to write files safely, to avoid race conditions",
+ "license": "BSD-2-Clause",
+ "keywords": [
+ "webimpress",
+ "safe writer",
+ "file writer",
+ "concurrent write",
+ "race condition"
+ ],
+ "require": {
+ "php": "^7.2"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^8.4.3",
+ "webimpress/coding-standard": "dev-develop"
+ },
+ "autoload": {
+ "psr-4": {
+ "Webimpress\\SafeWriter\\": "src/"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "WebimpressTest\\SafeWriter\\": "test/"
+ }
+ },
+ "config": {
+ "sort-packages": true
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.0.x-dev",
+ "dev-develop": "2.1.x-dev",
+ "dev-release-1.0": "1.0.x-dev"
+ }
+ },
+ "scripts": {
+ "check": [
+ "@cs-check",
+ "@test"
+ ],
+ "cs-check": "phpcs",
+ "cs-fix": "phpcbf",
+ "test": "phpunit --colors=always",
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ }
+}
diff --git a/php-webimpress-safe-writer-get-source.sh b/php-webimpress-safe-writer-get-source.sh
new file mode 100755
index 0000000..b2ac62b
--- /dev/null
+++ b/php-webimpress-safe-writer-get-source.sh
@@ -0,0 +1,73 @@
+#/bin/sh
+
+GIT=`which git`
+RPM=`which rpm`
+
+if [ -z "$GIT" ]
+then
+ echo "ERROR: 'git' command not found" 1>&2
+ exit 1
+elif [ -z "$RPM" ]
+then
+ echo "ERROR: 'rpm' command not found" 1>&2
+ exit 1
+fi
+
+function print {
+ echo -e "\e[0;33m>>>>> ${1}\e[0m"
+}
+
+if [ -x "$1" ]
+then
+ SPEC=$1
+else
+ SPEC=`ls *.spec | head -1`
+fi
+
+SPEC_DIR=`pwd`
+
+print "SPEC_DIR = $SPEC_DIR"
+
+NAME=`echo $SPEC | sed 's#\.spec##'`
+VERSION=`egrep '%global\s*github_version' $SPEC | awk '{print $3}'`
+
+print "SPEC = $SPEC"
+print "NAME = $NAME"
+
+GIT_OWNER=`egrep '%global\s*github_owner' $SPEC | awk '{print $3}'`
+GIT_NAME=`egrep '%global\s*github_name' $SPEC | awk '{print $3}'`
+GIT_COMMIT=`egrep '%global\s*github_commit' $SPEC | awk '{print $3}'`
+GIT_REPO=https://github.com/${GIT_OWNER}/${GIT_NAME}
+GIT_DIR=`echo $GIT_REPO | sed 's#.*/##'`
+
+print "GIT_OWNER = $GIT_OWNER"
+print "GIT_NAME = $GIT_NAME"
+print "GIT_COMMIT = $GIT_COMMIT"
+print "GIT_REPO = $GIT_REPO"
+print "GIT_DIR = $GIT_DIR"
+
+TEMP_DIR=$(mktemp --dir)
+
+pushd $TEMP_DIR
+ print "Cloning git repo..."
+ $GIT clone $GIT_REPO
+
+ pushd $GIT_DIR
+ print "Checking out commit..."
+ $GIT checkout $GIT_COMMIT
+ popd
+
+ TAR_DIR=${GIT_NAME}-${GIT_COMMIT}
+ print "TAR_DIR = $TAR_DIR"
+
+ mv $GIT_DIR $TAR_DIR
+
+ TAR_FILE=${SPEC_DIR}/${NAME}-${VERSION}-${GIT_COMMIT}.tar.gz
+ print "TAR_FILE = $TAR_FILE"
+
+ [ -e $TAR_FILE ] && rm -f $TAR_FILE
+ tar --exclude-vcs -czf $TAR_FILE $TAR_DIR
+ chmod 0644 $TAR_FILE
+popd
+
+rm -rf $TEMP_DIR
diff --git a/php-webimpress-safe-writer.spec b/php-webimpress-safe-writer.spec
new file mode 100644
index 0000000..3f2e70d
--- /dev/null
+++ b/php-webimpress-safe-writer.spec
@@ -0,0 +1,129 @@
+#
+# Fedora spec file for php-webimpress-safe-writer
+#
+# Copyright (c) 2020 Shawn Iwinski <shawn@iwin.ski>
+#
+# License: MIT
+# http://opensource.org/licenses/MIT
+#
+# Please preserve changelog entries
+#
+
+%global github_owner webimpress
+%global github_name safe-writer
+%global github_version 2.0.0
+%global github_commit d03bea3b98abe1d4c8b24cbebf524361ffaafee4
+
+%global composer_vendor webimpress
+%global composer_project safe-writer
+
+# "php": "^7.2"
+%global php_min_ver 7.2
+
+# Build using "--without tests" to disable tests
+%global with_tests 0%{!?_without_tests:1}
+
+%{!?phpdir: %global phpdir %{_datadir}/php}
+
+Name: php-%{composer_vendor}-%{composer_project}
+Version: %{github_version}
+Release: 1%{?github_release}%{?dist}
+Summary: Tool to write files safely, to avoid race conditions
+
+License: BSD
+URL: https://github.com/%{github_owner}/%{github_name}
+
+# GitHub export does not include tests
+# Run php-webimpress-safe-writer-get-source.sh to create full source
+Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
+Source1: %{name}-get-source.sh
+
+BuildArch: noarch
+# Tests
+%if %{with_tests}
+## composer.json
+BuildRequires: php(language) >= %{php_min_ver}
+BuildRequires: phpunit8
+## phpcompatinfo for version 2.0.0
+BuildRequires: php-json
+BuildRequires: php-spl
+## Autoloader
+BuildRequires: php-composer(fedora/autoloader)
+%endif
+
+# composer.json
+Requires: php(language) >= %{php_min_ver}
+# phpcompatinfo for version 2.0.0
+Requires: php-spl
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+# Composer
+Provides: php-composer(%{composer_vendor}/%{composer_project}) = %{version}
+
+%description
+Write files safely to avoid race conditions when the same file is written
+multiple times in a short time period.
+
+Autoloader: %{phpdir}/Webimpress/SafeWriter/autoload.php
+
+
+%prep
+%setup -qn %{github_name}-%{github_commit}
+
+mv LICENSE.md LICENSE
+
+
+%build
+: Create autoloader
+cat <<'AUTOLOAD' | tee src/autoload.php
+<?php
+/**
+ * Autoloader for %{name} and its' dependencies
+ * (created by %{name}-%{version}-%{release}).
+ */
+require_once '%{phpdir}/Fedora/Autoloader/autoload.php';
+
+\Fedora\Autoloader\Autoload::addPsr4('Webimpress\\SafeWriter\\', __DIR__);
+AUTOLOAD
+
+
+%install
+mkdir -p %{buildroot}%{phpdir}/Webimpress
+cp -rp src %{buildroot}%{phpdir}/Webimpress/SafeWriter
+
+
+%check
+%if %{with_tests}
+: Skip test known to fail in mock environment
+sed 's/function testMultipleWriters/function SKIP_testMultipleWriters/' \
+ -i test/FileWriterTest.php
+
+: Upstream tests
+RETURN_CODE=0
+PHPUNIT=$(which phpunit8)
+for PHP_EXEC in php php70 php71 php72 php73 php74; do
+ if [ "php" == "$PHP_EXEC" ] || which $PHP_EXEC; then
+ $PHP_EXEC $PHPUNIT --verbose \
+ --bootstrap %{buildroot}%{phpdir}/Webimpress/SafeWriter/autoload.php \
+ || RETURN_CODE=1
+ fi
+done
+exit $RETURN_CODE
+%else
+: Tests skipped
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%dir %{phpdir}/Webimpress
+ %{phpdir}/Webimpress/SafeWriter
+
+
+%changelog
+* Sun Feb 23 2020 Shawn Iwinski <shawn@iwin.ski> - 2.0.0-1
+- Initial package