summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-05-13 10:30:41 +0200
committerRemi Collet <remi@remirepo.net>2019-05-13 10:30:41 +0200
commit985ab5559d08dc448cda180e87dbb7812a90d310 (patch)
tree4971f7a452acd345e489b78c8994994f8e64c882
parentb67c8e627ce648a310cecaaf2070eb966024ef31 (diff)
sync with Fedora
-rw-r--r--composer.json5
l---------makesrc.sh1
-rw-r--r--php-typo3-phar-stream-wrapper.spec32
3 files changed, 29 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index 99b7365..939ce99 100644
--- a/composer.json
+++ b/composer.json
@@ -6,9 +6,12 @@
"homepage": "https://typo3.org/",
"keywords": ["php", "phar", "stream-wrapper", "security"],
"require": {
- "php": "^7.0"
+ "php": "^7.0",
+ "ext-fileinfo": "*",
+ "ext-json": "*"
},
"require-dev": {
+ "ext-xdebug": "*",
"phpunit/phpunit": "^6.5"
},
"autoload": {
diff --git a/makesrc.sh b/makesrc.sh
new file mode 120000
index 0000000..d94edbc
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1 @@
+php-typo3-phar-stream-wrapper-get-source.sh \ No newline at end of file
diff --git a/php-typo3-phar-stream-wrapper.spec b/php-typo3-phar-stream-wrapper.spec
index 7eaccad..bc75f48 100644
--- a/php-typo3-phar-stream-wrapper.spec
+++ b/php-typo3-phar-stream-wrapper.spec
@@ -12,14 +12,14 @@
%global github_owner TYPO3
%global github_name phar-stream-wrapper
-%global github_version 3.0.1
-%global github_commit b3cbcfd2e4de5943bf05ec975d42d0e8d85c0009
+%global github_version 3.1.1
+%global github_commit fff6f5e037882f816cd41a9f5ccd8d8f97bfdebf
%global composer_vendor typo3
%global composer_project phar-stream-wrapper
-# "php": "^5.3.3|^7.0"
-%global php_min_ver 5.3.3
+# "php": "^7.0"
+%global php_min_ver 7.0
# Build using "--without tests" to disable tests
%global with_tests 0%{!?_without_tests:1}
@@ -45,7 +45,10 @@ BuildArch: noarch
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-composer(phpunit/phpunit)
-## phpcompatinfo for version 3.0.1
+BuildRequires: php-fileinfo
+BuildRequires: php-json
+## phpcompatinfo for version 3.1.1
+BuildRequires: php-pcre
BuildRequires: php-pecl(opcache)
BuildRequires: php-spl
## Autoloader
@@ -54,7 +57,10 @@ BuildRequires: php-composer(fedora/autoloader)
# composer.json
Requires: php(language) >= %{php_min_ver}
-# phpcompatinfo for version 3.0.1
+Requires: php-fileinfo
+Requires: php-json
+# phpcompatinfo for version 3.1.1
+Requires: php-pcre
Requires: php-spl
# Autoloader
Requires: php-composer(fedora/autoloader)
@@ -102,17 +108,20 @@ cp -rp src %{buildroot}%{phpdir}/TYPO3/PharStreamWrapper
cat <<'BOOTSTRAP' | tee bootstrap.php
<?php
require '%{buildroot}%{phpdir}/TYPO3/PharStreamWrapper/autoload.php';
-\Fedora\Autoloader\Autoload::addPsr4('TYPO3\\PharStreamWrapper\\Test\\', __DIR__.'/tests');
+\Fedora\Autoloader\Autoload::addPsr4('TYPO3\\PharStreamWrapper\\Tests\\', __DIR__.'/tests');
if (!class_exists('PHPUnit\\Framework\\Error\\Warning')) {
class_alias('PHPUnit_Framework_Error_Warning', 'PHPUnit\\Framework\\Error\\Warning');
}
BOOTSTRAP
+: Skip tests known to fail in rpmbuild mock env
+rm -f tests/Functional/Interceptor/PharExtensionInterceptorTest.php
+
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which phpunit)
-for PHP_EXEC in php php70 php71 php72 php73; do
+for PHP_EXEC in php php71 php72 php73; do
if [ "php" == "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php || RETURN_CODE=1
fi
@@ -133,5 +142,12 @@ exit $RETURN_CODE
%changelog
+* Wed May 08 2019 Shawn Iwinski <shawn@iwin.ski> - 3.1.1-1
+- Update to 3.1.1 (RHBZ #1708651, #1708646, #1708649)
+- https://typo3.org/security/advisory/typo3-psa-2019-007/
+- https://nvd.nist.gov/vuln/detail/CVE-2019-11831
+- https://typo3.org/security/advisory/typo3-psa-2019-008/
+- https://nvd.nist.gov/vuln/detail/CVE-2019-11830
+
* Sat Feb 23 2019 Shawn Iwinski <shawn@iwin.ski> - 3.0.1-1
- Initial package