summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-02-26 11:13:04 +0100
committerRemi Collet <remi@remirepo.net>2019-02-26 11:13:04 +0100
commitb67c8e627ce648a310cecaaf2070eb966024ef31 (patch)
tree6b92b8831e3df5814a515e9e0205ff726035871f
parentfeab4910c213efa5199588dcad3b725c38daf576 (diff)
backport stuff
-rw-r--r--.gitignore8
-rw-r--r--Makefile4
-rw-r--r--composer.json24
-rwxr-xr-xphp-typo3-phar-stream-wrapper-get-source.sh1
-rw-r--r--php-typo3-phar-stream-wrapper.spec3
5 files changed, 39 insertions, 1 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..99b7365
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,24 @@
+{
+ "name": "typo3/phar-stream-wrapper",
+ "description": "Interceptors for PHP's native phar:// stream handling",
+ "type": "library",
+ "license": "MIT",
+ "homepage": "https://typo3.org/",
+ "keywords": ["php", "phar", "stream-wrapper", "security"],
+ "require": {
+ "php": "^7.0"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^6.5"
+ },
+ "autoload": {
+ "psr-4": {
+ "TYPO3\\PharStreamWrapper\\": "src/"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "TYPO3\\PharStreamWrapper\\Tests\\": "tests/"
+ }
+ }
+}
diff --git a/php-typo3-phar-stream-wrapper-get-source.sh b/php-typo3-phar-stream-wrapper-get-source.sh
index b2ac62b..3947de4 100755
--- a/php-typo3-phar-stream-wrapper-get-source.sh
+++ b/php-typo3-phar-stream-wrapper-get-source.sh
@@ -55,6 +55,7 @@ pushd $TEMP_DIR
pushd $GIT_DIR
print "Checking out commit..."
$GIT checkout $GIT_COMMIT
+ cp composer.json ${SPEC_DIR}/composer.json
popd
TAR_DIR=${GIT_NAME}-${GIT_COMMIT}
diff --git a/php-typo3-phar-stream-wrapper.spec b/php-typo3-phar-stream-wrapper.spec
index 999bf2f..7eaccad 100644
--- a/php-typo3-phar-stream-wrapper.spec
+++ b/php-typo3-phar-stream-wrapper.spec
@@ -1,3 +1,4 @@
+# remirepo spec file for php-typo3-phar-stream-wrapper, from:
#
# Fedora spec file for php-typo3-phar-stream-wrapper
#
@@ -59,7 +60,7 @@ Requires: php-spl
Requires: php-composer(fedora/autoloader)
# Weak dependencies
-%if 0%{?fedora} >= 21
+%if 0%{?fedora} >= 21 || 0%{?rhel} >= 8
Suggests: php-pecl(opcache)
%endif