summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-09-02 14:12:43 +0200
committerRemi Collet <fedora@famillecollet.com>2016-09-02 14:12:43 +0200
commit5ffa2fedf66b2eaccab263f2461ed875d52c2f12 (patch)
tree124f657e5737d4ca6c7167c74f0cef2a577d1dc2
parent91bb107e27905f9caca86d09f587d4a24ab680d4 (diff)
php-tecnickcom-tc-lib-unicode: 1.3.3 (no change)
-rw-r--r--composer.json2
-rw-r--r--php-tecnickcom-tc-lib-unicode.spec29
2 files changed, 23 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index 05a19cf..d0fda29 100644
--- a/composer.json
+++ b/composer.json
@@ -14,7 +14,7 @@
],
"require": {
"php": ">=5.4",
- "tecnickcom/tc-lib-unicode-data": "^1.6.0"
+ "tecnickcom/tc-lib-unicode-data": "^1.6.3"
},
"require-dev": {
"apigen/apigen" : "^4.1.2",
diff --git a/php-tecnickcom-tc-lib-unicode.spec b/php-tecnickcom-tc-lib-unicode.spec
index a51bea7..7f1b569 100644
--- a/php-tecnickcom-tc-lib-unicode.spec
+++ b/php-tecnickcom-tc-lib-unicode.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 363376cb4a340dc6d6060aff312ca45d7d0ee77a
+%global gh_commit 632975705e2d6e620ae67e4b40f9ccdbb4a39afa
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.3.0
+Version: 1.3.3
Release: 1%{?dist}
Summary: PHP library containing Unicode methods
@@ -30,7 +30,7 @@ BuildArch: noarch
# For tests
BuildRequires: php-composer(phpunit/phpunit)
BuildRequires: php(language) >= 5.4
-BuildRequires: php-composer(%{c_vendor}/tc-lib-unicode-data) >= 1.5.0
+BuildRequires: php-composer(%{c_vendor}/tc-lib-unicode-data) >= 1.6.3
BuildRequires: php-mbstring
BuildRequires: php-pcre
%endif
@@ -39,7 +39,7 @@ BuildRequires: php-pcre
# "php": ">=5.4"
# "tecnickcom/tc-lib-unicode-data": "^1.6.0"
Requires: php(language) >= 5.4
-Requires: php-composer(%{c_vendor}/tc-lib-unicode-data) >= 1.6.0
+Requires: php-composer(%{c_vendor}/tc-lib-unicode-data) >= 1.6.3
Requires: php-composer(%{c_vendor}/tc-lib-unicode-data) < 2
# From phpcompatinfo report for version 1.2.1
Requires: php-mbstring
@@ -86,11 +86,22 @@ require '%{buildroot}%{php_project}/autoload.php';
require '%{php_project}/Data/autoload.php';
EOF
+# remirepo:11
+run=0
+ret=0
+if which php56; then
+ php56 %{_bindir}/phpunit || ret=1
+ run=1
+fi
+if which php71; then
+ php71 %{_bindir}/phpunit || ret=1
+ run=1
+fi
+if [ $run -eq 0 ]; then
%{_bindir}/phpunit --verbose
-
-if which php70; then
- php70 %{_bindir}/phpunit --verbose
+# remirepo:2
fi
+exit $ret
%else
: Test suite disabled
%endif
@@ -110,6 +121,10 @@ rm -rf %{buildroot}
%changelog
+* Fri Sep 2 2016 Remi Collet <remi@fedoraproject.org> - 1.3.3-1
+- update to 1.3.3 (no change)
+- raise dependency on tecnickcom/tc-lib-unicode-data >= 1.6.3
+
* Tue Jun 14 2016 Remi Collet <remi@fedoraproject.org> - 1.3.0-1
- update to 1.3.0 (no change)