summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-06-14 07:27:37 +0200
committerRemi Collet <fedora@famillecollet.com>2016-06-14 07:27:37 +0200
commit91bb107e27905f9caca86d09f587d4a24ab680d4 (patch)
treefcf55049e864f9956e3c488c0fd8aa0ff8cb24fd
parent41431df076de19fa8460c0558889035ffae63694 (diff)
php-tecnickcom-tc-lib-unicode: 1.3.0 (no change)
-rw-r--r--composer.json40
-rw-r--r--php-tecnickcom-tc-lib-unicode.spec11
2 files changed, 47 insertions, 4 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..05a19cf
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,40 @@
+{
+ "name": "tecnickcom/tc-lib-unicode",
+ "description": "PHP library containing Unicode methods",
+ "type": "library",
+ "homepage": "http://www.tecnick.com",
+ "license": "LGPL-3.0",
+ "keywords": ["tc-lib-unicode", "PDF", "font", "UTF-8"],
+ "authors": [
+ {
+ "name": "Nicola Asuni",
+ "email": "info@tecnick.com",
+ "role": "lead"
+ }
+ ],
+ "require": {
+ "php": ">=5.4",
+ "tecnickcom/tc-lib-unicode-data": "^1.6.0"
+ },
+ "require-dev": {
+ "apigen/apigen" : "^4.1.2",
+ "bartlett/php-compatinfo" : "^5.0.0",
+ "pdepend/pdepend" : "^2.2.2",
+ "phploc/phploc" : "^2.1.5|^3.0.0",
+ "phpmd/phpmd" : "^2.3.2",
+ "phpunit/phpunit": "4.8.19|^5.0.0",
+ "sebastian/phpcpd" : "^2.0.2",
+ "squizlabs/php_codesniffer": "^2.5.0|^3.0.0"
+ },
+ "autoload": {
+ "psr-4":{
+ "Com\\Tecnick\\Unicode\\": "src"
+ }
+ },
+ "repositories": [
+ {
+ "type": "vcs",
+ "url": "git@github.com:tecnickcom/tc-lib-unicode-data.git"
+ }
+ ]
+}
diff --git a/php-tecnickcom-tc-lib-unicode.spec b/php-tecnickcom-tc-lib-unicode.spec
index 477fcb6..a51bea7 100644
--- a/php-tecnickcom-tc-lib-unicode.spec
+++ b/php-tecnickcom-tc-lib-unicode.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit a1341f719c678703207da0073719e28a9bbdacb5
+%global gh_commit 363376cb4a340dc6d6060aff312ca45d7d0ee77a
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.2.2
+Version: 1.3.0
Release: 1%{?dist}
Summary: PHP library containing Unicode methods
@@ -37,9 +37,9 @@ BuildRequires: php-pcre
# From composer.json, "require": {
# "php": ">=5.4"
-# "tecnickcom/tc-lib-unicode-data": "^1.5.0"
+# "tecnickcom/tc-lib-unicode-data": "^1.6.0"
Requires: php(language) >= 5.4
-Requires: php-composer(%{c_vendor}/tc-lib-unicode-data) >= 1.5.0
+Requires: php-composer(%{c_vendor}/tc-lib-unicode-data) >= 1.6.0
Requires: php-composer(%{c_vendor}/tc-lib-unicode-data) < 2
# From phpcompatinfo report for version 1.2.1
Requires: php-mbstring
@@ -110,6 +110,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Jun 14 2016 Remi Collet <remi@fedoraproject.org> - 1.3.0-1
+- update to 1.3.0 (no change)
+
* Fri Mar 4 2016 Remi Collet <remi@fedoraproject.org> - 1.2.2-1
- update to 1.2.2 (no change)