summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-05-03 09:16:18 +0200
committerRemi Collet <remi@php.net>2023-05-03 09:16:18 +0200
commit4fb80036c048adcbaa32ce4453186900b9e10e8d (patch)
tree16a382d9864f3ea8be2cc3774a3bbf3bb7bf14fd
parent43b3cbca39fc646bf57238e8439cb83505c1ff17 (diff)
update to 1.4.14 (no change)
-rw-r--r--composer.json6
-rw-r--r--php-tecnickcom-tc-lib-unicode.spec15
2 files changed, 12 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index a846262..e469ff5 100644
--- a/composer.json
+++ b/composer.json
@@ -25,12 +25,12 @@
"tecnickcom/tc-lib-unicode-data": "^1.7"
},
"require-dev": {
- "pdepend/pdepend": "2.12.1",
+ "pdepend/pdepend": "2.13.0",
"phploc/phploc": "7.0.2 || 6.0.2 || 5.0.0 || 4.0.1 || 3.0.1 || 2.1.5",
"phpmd/phpmd": "2.13.0",
- "phpunit/phpunit": "9.5.27 || 8.5.31 || 7.5.20 || 6.5.14 || 5.7.27 || 4.8.36",
+ "phpunit/phpunit": "10.1.2 || 9.6.7 || 8.5.31 || 7.5.20 || 6.5.14 || 5.7.27 || 4.8.36",
"sebastian/phpcpd": "6.0.3 || 5.0.2 || 4.1.0 || 3.0.1 || 2.0.4",
- "squizlabs/php_codesniffer": "3.7.1 || 2.9.2"
+ "squizlabs/php_codesniffer": "3.7.2 || 2.9.2"
},
"autoload": {
"psr-4": {
diff --git a/php-tecnickcom-tc-lib-unicode.spec b/php-tecnickcom-tc-lib-unicode.spec
index 58c9634..14d6488 100644
--- a/php-tecnickcom-tc-lib-unicode.spec
+++ b/php-tecnickcom-tc-lib-unicode.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-tecnickcom-tc-lib-unicode
#
-# Copyright (c) 2016-2022 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2016-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit 634cf7b54e09578aa2128c3d1a3e6d0dd08201bd
+%global gh_commit 39cc49285ac214be1796b9e4af43bc96e41c6415
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.4.13
+Version: 1.4.14
Release: 1%{?dist}
Summary: PHP library containing Unicode methods
@@ -102,10 +102,10 @@ require '%{buildroot}%{php_project}/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" php80 php81 php82; do
+for cmdarg in "php %{phpunit}" "php80 %{phpunit}" php81 php82; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit9} --no-coverage --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit10} --no-coverage || ret=1
fi
done
exit $ret
@@ -123,6 +123,9 @@ exit $ret
%changelog
+* Wed May 3 2023 Remi Collet <remi@remirepo.net> - 1.4.14-1
+- update to 1.4.14 (no change)
+
* Thu Dec 22 2022 Remi Collet <remi@remirepo.net> - 1.4.13-1
- update to 1.4.13 (no change)