summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-12-22 09:39:35 +0100
committerRemi Collet <remi@php.net>2022-12-22 09:39:35 +0100
commit43b3cbca39fc646bf57238e8439cb83505c1ff17 (patch)
treee9fd13c85425b9f20d1f4397166c797bbffb39e0
parent2f7473021d7542207321331001b1ce9d9b736245 (diff)
update to 1.4.13 (no change)
-rw-r--r--composer.json8
-rw-r--r--php-tecnickcom-tc-lib-unicode.spec13
2 files changed, 12 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index 37b1742..a846262 100644
--- a/composer.json
+++ b/composer.json
@@ -25,12 +25,12 @@
"tecnickcom/tc-lib-unicode-data": "^1.7"
},
"require-dev": {
- "pdepend/pdepend": "2.10.2",
+ "pdepend/pdepend": "2.12.1",
"phploc/phploc": "7.0.2 || 6.0.2 || 5.0.0 || 4.0.1 || 3.0.1 || 2.1.5",
- "phpmd/phpmd": "2.11.1",
- "phpunit/phpunit": "9.5.11 || 8.5.13 || 7.5.20 || 6.5.14 || 5.7.27 || 4.8.36",
+ "phpmd/phpmd": "2.13.0",
+ "phpunit/phpunit": "9.5.27 || 8.5.31 || 7.5.20 || 6.5.14 || 5.7.27 || 4.8.36",
"sebastian/phpcpd": "6.0.3 || 5.0.2 || 4.1.0 || 3.0.1 || 2.0.4",
- "squizlabs/php_codesniffer": "3.6.2 || 2.9.2"
+ "squizlabs/php_codesniffer": "3.7.1 || 2.9.2"
},
"autoload": {
"psr-4": {
diff --git a/php-tecnickcom-tc-lib-unicode.spec b/php-tecnickcom-tc-lib-unicode.spec
index 9e94a7d..58c9634 100644
--- a/php-tecnickcom-tc-lib-unicode.spec
+++ b/php-tecnickcom-tc-lib-unicode.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit d032df898643379ee5bfaa45162fb02defaf16b8
+%global gh_commit 634cf7b54e09578aa2128c3d1a3e6d0dd08201bd
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,11 +15,11 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.4.9
+Version: 1.4.13
Release: 1%{?dist}
Summary: PHP library containing Unicode methods
-License: LGPLv3+
+License: LGPL-3.0-or-later
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{?gh_short}.tar.gz
@@ -27,7 +27,7 @@ BuildArch: noarch
%if %{with_tests}
# For tests
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.5.0
+BuildRequires: phpunit9 >= 9.5.27
BuildRequires: php(language) >= 5.4
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(%{c_vendor}/tc-lib-unicode-data) >= 1.7 with php-composer(%{c_vendor}/tc-lib-unicode-data) < 2)
@@ -102,7 +102,7 @@ require '%{buildroot}%{php_project}/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" php74 php80 php81 php82; do
+for cmdarg in "php %{phpunit}" php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --no-coverage --verbose || ret=1
@@ -123,6 +123,9 @@ exit $ret
%changelog
+* Thu Dec 22 2022 Remi Collet <remi@remirepo.net> - 1.4.13-1
+- update to 1.4.13 (no change)
+
* Tue Jun 14 2022 Remi Collet <remi@remirepo.net> - 1.4.9-1
- update to 1.4.9 (no change)