summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-05-14 07:16:42 +0200
committerRemi Collet <remi@remirepo.net>2018-05-14 07:16:42 +0200
commitec2a82cae6e40f1897871ea2ce4da2222920162f (patch)
tree3ba3826bb3aa9fdfe3904ccadb8f867e6c934355
parent67ba489876b15729a2d7fd375fb2ee46e5f176e8 (diff)
update to 2.3.7 (no change)
switch to phpunit7 use range dependencies
-rw-r--r--composer.json14
-rw-r--r--php-tecnickcom-tc-lib-pdf-parser.spec31
2 files changed, 32 insertions, 13 deletions
diff --git a/composer.json b/composer.json
index ad8c4b7..464846a 100644
--- a/composer.json
+++ b/composer.json
@@ -20,17 +20,17 @@
"require": {
"php": ">=5.4",
"ext-pcre": "*",
- "tecnickcom/tc-lib-pdf-filter": "^1.3.6"
+ "tecnickcom/tc-lib-pdf-filter": "^1.3.7"
},
"require-dev": {
"apigen/apigen": "^4.1.2",
- "bartlett/php-compatinfo": "^5.0.4",
- "pdepend/pdepend": "^2.5.0",
- "phploc/phploc": "^2.1.5 || ^3.0.1",
+ "bartlett/php-compatinfo": "^5.0.10 || ^5.0.12",
+ "pdepend/pdepend": "^2.5.2",
+ "phploc/phploc": "^2.1 || ^3.0 || ^4.0",
"phpmd/phpmd": "^2.6.0",
- "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.0",
- "sebastian/phpcpd": "^2.0.4 || 3.0.0",
- "squizlabs/php_codesniffer": "^2.8.0 || ^3.0.0"
+ "phpunit/phpunit": "^4.8 || ^5.7 || ^6.5 || ^7.1",
+ "sebastian/phpcpd": "^2.0 || ^3.0 || ^4.0",
+ "squizlabs/php_codesniffer": "^2.8.0 || ^3.2.0"
},
"autoload": {
"psr-4": {
diff --git a/php-tecnickcom-tc-lib-pdf-parser.spec b/php-tecnickcom-tc-lib-pdf-parser.spec
index 4965fb0..26138bf 100644
--- a/php-tecnickcom-tc-lib-pdf-parser.spec
+++ b/php-tecnickcom-tc-lib-pdf-parser.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 4f2021f0728cbb68a1046d096566a8940d9eb528
+%global gh_commit 0c15cd230b3c3015cdaf4f66bb885c7cb1d4f20a
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.3.6
+Version: 2.3.7
Release: 1%{?dist}
Summary: PHP library to parse PDF documents
@@ -27,9 +27,19 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
BuildArch: noarch
%if %{with_tests}
# For tests
-BuildRequires: php-composer(phpunit/phpunit)
+%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
+%global phpunit %{_bindir}/phpunit7
+%else
+%global phpunit %{_bindir}/phpunit
+%endif
+BuildRequires: %{phpunit}
BuildRequires: php(language) >= 5.4
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(%{c_vendor}/tc-lib-pdf-filter) >= 1.3.3 with php-composer(%{c_vendor}/tc-lib-pdf-filter) < 2)
+%else
+BuildRequires: php-composer(%{c_vendor}/tc-lib-pdf-filter) < 2
BuildRequires: php-composer(%{c_vendor}/tc-lib-pdf-filter) >= 1.3.3
+%endif
BuildRequires: php-pcre
%endif
@@ -39,8 +49,12 @@ BuildRequires: php-pcre
# "tecnickcom/tc-lib-pdf-filter": "^1.3.4"
Requires: php(language) >= 5.4
Requires: php-pcre
-Requires: php-composer(%{c_vendor}/tc-lib-pdf-filter) >= 1.3.3
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(%{c_vendor}/tc-lib-pdf-filter) >= 1.3.3 with php-composer(%{c_vendor}/tc-lib-pdf-filter) < 2)
+%else
Requires: php-composer(%{c_vendor}/tc-lib-pdf-filter) < 2
+Requires: php-composer(%{c_vendor}/tc-lib-pdf-filter) >= 1.3.3
+%endif
# From phpcompatinfo report for version 2.1.0
# None
@@ -91,10 +105,10 @@ require '%{php_project}/../Filter/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" "php70 %{_bindir}/phpunit6" php71 php72; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit6} --no-coverage --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit7} --no-coverage --verbose || ret=1
fi
done
exit $ret
@@ -112,6 +126,11 @@ exit $ret
%changelog
+* Mon May 14 2018 Remi Collet <remi@remirepo.net> - 2.3.7-1
+- update to 2.3.7 (no change)
+- switch to phpunit7
+- use range dependencies
+
* Tue Jan 2 2018 Remi Collet <remi@remirepo.net> - 2.3.6-1
- Update to 2.3.6 (no change)