summaryrefslogtreecommitdiffstats
path: root/php-tecnickcom-tc-lib-pdf-parser.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-tecnickcom-tc-lib-pdf-parser.spec')
-rw-r--r--php-tecnickcom-tc-lib-pdf-parser.spec31
1 files changed, 25 insertions, 6 deletions
diff --git a/php-tecnickcom-tc-lib-pdf-parser.spec b/php-tecnickcom-tc-lib-pdf-parser.spec
index 4965fb0..26138bf 100644
--- a/php-tecnickcom-tc-lib-pdf-parser.spec
+++ b/php-tecnickcom-tc-lib-pdf-parser.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 4f2021f0728cbb68a1046d096566a8940d9eb528
+%global gh_commit 0c15cd230b3c3015cdaf4f66bb885c7cb1d4f20a
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.3.6
+Version: 2.3.7
Release: 1%{?dist}
Summary: PHP library to parse PDF documents
@@ -27,9 +27,19 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
BuildArch: noarch
%if %{with_tests}
# For tests
-BuildRequires: php-composer(phpunit/phpunit)
+%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
+%global phpunit %{_bindir}/phpunit7
+%else
+%global phpunit %{_bindir}/phpunit
+%endif
+BuildRequires: %{phpunit}
BuildRequires: php(language) >= 5.4
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(%{c_vendor}/tc-lib-pdf-filter) >= 1.3.3 with php-composer(%{c_vendor}/tc-lib-pdf-filter) < 2)
+%else
+BuildRequires: php-composer(%{c_vendor}/tc-lib-pdf-filter) < 2
BuildRequires: php-composer(%{c_vendor}/tc-lib-pdf-filter) >= 1.3.3
+%endif
BuildRequires: php-pcre
%endif
@@ -39,8 +49,12 @@ BuildRequires: php-pcre
# "tecnickcom/tc-lib-pdf-filter": "^1.3.4"
Requires: php(language) >= 5.4
Requires: php-pcre
-Requires: php-composer(%{c_vendor}/tc-lib-pdf-filter) >= 1.3.3
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(%{c_vendor}/tc-lib-pdf-filter) >= 1.3.3 with php-composer(%{c_vendor}/tc-lib-pdf-filter) < 2)
+%else
Requires: php-composer(%{c_vendor}/tc-lib-pdf-filter) < 2
+Requires: php-composer(%{c_vendor}/tc-lib-pdf-filter) >= 1.3.3
+%endif
# From phpcompatinfo report for version 2.1.0
# None
@@ -91,10 +105,10 @@ require '%{php_project}/../Filter/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" "php70 %{_bindir}/phpunit6" php71 php72; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit6} --no-coverage --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit7} --no-coverage --verbose || ret=1
fi
done
exit $ret
@@ -112,6 +126,11 @@ exit $ret
%changelog
+* Mon May 14 2018 Remi Collet <remi@remirepo.net> - 2.3.7-1
+- update to 2.3.7 (no change)
+- switch to phpunit7
+- use range dependencies
+
* Tue Jan 2 2018 Remi Collet <remi@remirepo.net> - 2.3.6-1
- Update to 2.3.6 (no change)