summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-01-02 09:36:29 +0100
committerRemi Collet <remi@remirepo.net>2018-01-02 09:36:29 +0100
commit82bc7f9e5e3ec682616cfcd9a6176a1d42176e8d (patch)
treedf19645f69f315c61913ae51d10680977c549513
parentb4302550f1ff7f22e5e517662862f584fb1fbb49 (diff)
v2.3.6
-rw-r--r--.gitignore8
-rw-r--r--composer.json77
-rw-r--r--php-tecnickcom-tc-lib-pdf-parser.spec29
3 files changed, 58 insertions, 56 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/composer.json b/composer.json
index e7860f3..ad8c4b7 100644
--- a/composer.json
+++ b/composer.json
@@ -1,41 +1,40 @@
{
- "name": "tecnickcom/tc-lib-pdf-parser",
- "description": "PHP library to parse PDF documents",
- "type": "library",
- "homepage": "http://www.tecnick.com",
- "license": "LGPL-3.0",
- "keywords": ["tc-lib-pdf-parser", "PDF", "parser", "document"],
- "authors": [
- {
- "name": "Nicola Asuni",
- "email": "info@tecnick.com",
- "role": "lead"
- }
- ],
- "require": {
- "php": ">=5.4",
- "ext-pcre": "*",
- "tecnickcom/tc-lib-pdf-filter": "^1.3.5"
- },
- "require-dev": {
- "apigen/apigen" : "^4.1.2",
- "bartlett/php-compatinfo" : "^5.0.4",
- "pdepend/pdepend" : "^2.5.0",
- "phploc/phploc" : "^2.1.5 || ^3.0.1",
- "phpmd/phpmd" : "^2.6.0",
- "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.0",
- "sebastian/phpcpd" : "^2.0.4 || 3.0.0",
- "squizlabs/php_codesniffer": "^2.8.0 || ^3.0.0"
- },
- "autoload": {
- "psr-4":{
- "Com\\Tecnick\\Pdf\\Parser\\": "src"
- }
- },
- "repositories": [
- {
- "type": "vcs",
- "url": "git@github.com:tecnickcom/tc-lib-pdf-filter.git"
- }
- ]
+ "name": "tecnickcom/tc-lib-pdf-parser",
+ "description": "PHP library to parse PDF documents",
+ "type": "library",
+ "homepage": "http://www.tecnick.com",
+ "license": "LGPL-3.0",
+ "keywords": [
+ "tc-lib-pdf-parser",
+ "PDF",
+ "parser",
+ "document"
+ ],
+ "authors": [
+ {
+ "name": "Nicola Asuni",
+ "email": "info@tecnick.com",
+ "role": "lead"
+ }
+ ],
+ "require": {
+ "php": ">=5.4",
+ "ext-pcre": "*",
+ "tecnickcom/tc-lib-pdf-filter": "^1.3.6"
+ },
+ "require-dev": {
+ "apigen/apigen": "^4.1.2",
+ "bartlett/php-compatinfo": "^5.0.4",
+ "pdepend/pdepend": "^2.5.0",
+ "phploc/phploc": "^2.1.5 || ^3.0.1",
+ "phpmd/phpmd": "^2.6.0",
+ "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.0",
+ "sebastian/phpcpd": "^2.0.4 || 3.0.0",
+ "squizlabs/php_codesniffer": "^2.8.0 || ^3.0.0"
+ },
+ "autoload": {
+ "psr-4": {
+ "Com\\Tecnick\\Pdf\\Parser\\": "src"
+ }
+ }
}
diff --git a/php-tecnickcom-tc-lib-pdf-parser.spec b/php-tecnickcom-tc-lib-pdf-parser.spec
index 9f80e36..6312dc3 100644
--- a/php-tecnickcom-tc-lib-pdf-parser.spec
+++ b/php-tecnickcom-tc-lib-pdf-parser.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-tecnickcom-tc-lib-pdf-parser
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit e841cb6be3747ad27cd7c4523b96787abfc390a7
+%global gh_commit 4f2021f0728cbb68a1046d096566a8940d9eb528
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.3.5
+Version: 2.3.6
Release: 1%{?dist}
Summary: PHP library to parse PDF documents
@@ -24,7 +24,6 @@ License: LGPLv3+
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{?gh_short}.tar.gz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
%if %{with_tests}
# For tests
@@ -76,7 +75,6 @@ ln resources/test/example_036.pdf example
%install
-rm -rf %{buildroot}
mkdir -p $(dirname %{buildroot}%{php_project})
cp -pr src %{buildroot}%{php_project}
cp -p resources/autoload.php \
@@ -93,14 +91,13 @@ require '%{php_project}/../Filter/autoload.php';
EOF
ret=0
-for cmd in php56 php; do
+for cmd in "php %{phpunit}" \
+ "php56 %{_bindir}/phpunit" \
+ "php70 %{_bindir}/phpunit6" \
+ "php71 %{_bindir}/phpunit6" \
+ "php72 %{_bindir}/phpunit6"; do
if which $cmd; then
- $cmd %{_bindir}/phpunit --verbose || ret=1
- fi
-done
-for cmd in php70 php71; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit6 --verbose || ret=1
+ $cmd --no-coverage --verbose || ret=1
fi
done
exit $ret
@@ -109,12 +106,7 @@ exit $ret
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc composer.json
@@ -123,6 +115,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Jan 2 2018 Remi Collet <remi@remirepo.net> - 2.3.6-1
+- Update to 2.3.6 (no change)
+
* Sun Feb 12 2017 Remi Collet <remi@remirepo.net> - 2.3.5-1
- update to 2.3.5 (no change)