summaryrefslogtreecommitdiffstats
path: root/php-tecnickcom-tc-lib-pdf-parser.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-tecnickcom-tc-lib-pdf-parser.spec')
-rw-r--r--php-tecnickcom-tc-lib-pdf-parser.spec29
1 files changed, 12 insertions, 17 deletions
diff --git a/php-tecnickcom-tc-lib-pdf-parser.spec b/php-tecnickcom-tc-lib-pdf-parser.spec
index 9f80e36..6312dc3 100644
--- a/php-tecnickcom-tc-lib-pdf-parser.spec
+++ b/php-tecnickcom-tc-lib-pdf-parser.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-tecnickcom-tc-lib-pdf-parser
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit e841cb6be3747ad27cd7c4523b96787abfc390a7
+%global gh_commit 4f2021f0728cbb68a1046d096566a8940d9eb528
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.3.5
+Version: 2.3.6
Release: 1%{?dist}
Summary: PHP library to parse PDF documents
@@ -24,7 +24,6 @@ License: LGPLv3+
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{?gh_short}.tar.gz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
%if %{with_tests}
# For tests
@@ -76,7 +75,6 @@ ln resources/test/example_036.pdf example
%install
-rm -rf %{buildroot}
mkdir -p $(dirname %{buildroot}%{php_project})
cp -pr src %{buildroot}%{php_project}
cp -p resources/autoload.php \
@@ -93,14 +91,13 @@ require '%{php_project}/../Filter/autoload.php';
EOF
ret=0
-for cmd in php56 php; do
+for cmd in "php %{phpunit}" \
+ "php56 %{_bindir}/phpunit" \
+ "php70 %{_bindir}/phpunit6" \
+ "php71 %{_bindir}/phpunit6" \
+ "php72 %{_bindir}/phpunit6"; do
if which $cmd; then
- $cmd %{_bindir}/phpunit --verbose || ret=1
- fi
-done
-for cmd in php70 php71; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit6 --verbose || ret=1
+ $cmd --no-coverage --verbose || ret=1
fi
done
exit $ret
@@ -109,12 +106,7 @@ exit $ret
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc composer.json
@@ -123,6 +115,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Jan 2 2018 Remi Collet <remi@remirepo.net> - 2.3.6-1
+- Update to 2.3.6 (no change)
+
* Sun Feb 12 2017 Remi Collet <remi@remirepo.net> - 2.3.5-1
- update to 2.3.5 (no change)