summaryrefslogtreecommitdiffstats
path: root/php-tecnickcom-tc-lib-pdf-page.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-05-14 07:13:00 +0200
committerRemi Collet <remi@remirepo.net>2018-05-14 07:13:00 +0200
commit9505afa52da5325dd25f906e99aeb35f90483aff (patch)
tree2c0f70b69b8c6f5af69d97e844767ba85736c277 /php-tecnickcom-tc-lib-pdf-page.spec
parentfd39bf1bfc88e51c423fc5cd9a2c0412d2a7dec6 (diff)
update to 2.4.6 (no change)
switch to phpunit7 use range dependencies
Diffstat (limited to 'php-tecnickcom-tc-lib-pdf-page.spec')
-rw-r--r--php-tecnickcom-tc-lib-pdf-page.spec42
1 files changed, 32 insertions, 10 deletions
diff --git a/php-tecnickcom-tc-lib-pdf-page.spec b/php-tecnickcom-tc-lib-pdf-page.spec
index cd30090..25d8c98 100644
--- a/php-tecnickcom-tc-lib-pdf-page.spec
+++ b/php-tecnickcom-tc-lib-pdf-page.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 43e0e6f95e4b64e85d068b03df4e0739f842507b
+%global gh_commit 2e10110e750386f65f72463b25c27d66981aa59f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.4.4
+Version: 2.4.6
Release: 1%{?dist}
Summary: PHP library containing PDF page formats and definitions
@@ -27,10 +27,22 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
BuildArch: noarch
%if %{with_tests}
# For tests
-BuildRequires: php-composer(phpunit/phpunit)
+%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
+%global phpunit %{_bindir}/phpunit7
+%else
+%global phpunit %{_bindir}/phpunit
+%endif
+BuildRequires: %{phpunit}
BuildRequires: php(language) >= 5.4
-BuildRequires: php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 1.4.3
-BuildRequires: php-composer(%{c_vendor}/tc-lib-color) >= 1.12.1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(%{c_vendor}/tc-lib-color) >= 1.12.1 with php-composer(%{c_vendor}/tc-lib-color) < 2)
+BuildRequires: (php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 1.5.2 with php-composer(%{c_vendor}/tc-lib-pdf-encrypt) < 2)
+%else
+BuildRequires: php-composer(%{c_vendor}/tc-lib-color) < 2
+BuildRequires: php-composer(%{c_vendor}/tc-lib-color) >= 1.12.1
+BuildRequires: php-composer(%{c_vendor}/tc-lib-pdf-encrypt) < 2
+BuildRequires: php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 1.5.2
+%endif
BuildRequires: php-date
BuildRequires: php-zlib
%endif
@@ -44,10 +56,15 @@ BuildRequires: php-zlib
Requires: php(language) >= 5.4
Requires: php-date
Requires: php-zlib
-Requires: php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 1.4.3
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(%{c_vendor}/tc-lib-color) >= 1.12.6 with php-composer(%{c_vendor}/tc-lib-color) < 2)
+Requires: (php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 1.5.2 with php-composer(%{c_vendor}/tc-lib-pdf-encrypt) < 2)
+%else
+Requires: php-composer(%{c_vendor}/tc-lib-color) < 2
+Requires: php-composer(%{c_vendor}/tc-lib-color) >= 1.12.6
Requires: php-composer(%{c_vendor}/tc-lib-pdf-encrypt) < 2
-Requires: php-composer(%{c_vendor}/tc-lib-color) >= 1.12.1
-Requires: php-composer(%{c_vendor}/tc-lib-color) < 2
+Requires: php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 1.5.2
+%endif
# From phpcompatinfo report for version 2.0.1
# None
@@ -91,10 +108,10 @@ require '%{php_project}/../../Color/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" "php70 %{_bindir}/phpunit6" php71 php72; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit6} --no-coverage --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit7} --no-coverage --verbose || ret=1
fi
done
exit $ret
@@ -112,6 +129,11 @@ exit $ret
%changelog
+* Mon May 14 2018 Remi Collet <remi@remirepo.net> - 2.4.6-1
+- update to 2.4.6 (no change)
+- switch to phpunit7
+- use range dependencies
+
* Tue Jan 2 2018 Remi Collet <remi@remirepo.net> - 2.4.4-1
- Update to 2.4.4