summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-05-14 07:13:00 +0200
committerRemi Collet <remi@remirepo.net>2018-05-14 07:13:00 +0200
commit9505afa52da5325dd25f906e99aeb35f90483aff (patch)
tree2c0f70b69b8c6f5af69d97e844767ba85736c277
parentfd39bf1bfc88e51c423fc5cd9a2c0412d2a7dec6 (diff)
update to 2.4.6 (no change)
switch to phpunit7 use range dependencies
-rw-r--r--composer.json16
-rw-r--r--php-tecnickcom-tc-lib-pdf-page.spec42
2 files changed, 40 insertions, 18 deletions
diff --git a/composer.json b/composer.json
index fce1260..921b1ef 100644
--- a/composer.json
+++ b/composer.json
@@ -21,18 +21,18 @@
"php": ">=5.4",
"ext-date": "*",
"ext-zlib": "*",
- "tecnickcom/tc-lib-color": "^1.12.7",
- "tecnickcom/tc-lib-pdf-encrypt": "^1.5.4"
+ "tecnickcom/tc-lib-color": "^1.12.10",
+ "tecnickcom/tc-lib-pdf-encrypt": "^1.5.6"
},
"require-dev": {
"apigen/apigen": "^4.1.2",
- "bartlett/php-compatinfo": "^5.0.4",
- "pdepend/pdepend": "^2.5.0",
- "phploc/phploc": "^2.1.5 || ^3.0.1",
+ "bartlett/php-compatinfo": "^5.0.10 || ^5.0.12",
+ "pdepend/pdepend": "^2.5.2",
+ "phploc/phploc": "^2.1 || ^3.0 || ^4.0",
"phpmd/phpmd": "^2.6.0",
- "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.0",
- "sebastian/phpcpd": "^2.0.4 || 3.0.0",
- "squizlabs/php_codesniffer": "^2.8.0 || ^3.0.0"
+ "phpunit/phpunit": "^4.8 || ^5.7 || ^6.5 || ^7.1",
+ "sebastian/phpcpd": "^2.0 || ^3.0 || ^4.0",
+ "squizlabs/php_codesniffer": "^2.8.0 || ^3.2.0"
},
"autoload": {
"psr-4": {
diff --git a/php-tecnickcom-tc-lib-pdf-page.spec b/php-tecnickcom-tc-lib-pdf-page.spec
index cd30090..25d8c98 100644
--- a/php-tecnickcom-tc-lib-pdf-page.spec
+++ b/php-tecnickcom-tc-lib-pdf-page.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 43e0e6f95e4b64e85d068b03df4e0739f842507b
+%global gh_commit 2e10110e750386f65f72463b25c27d66981aa59f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.4.4
+Version: 2.4.6
Release: 1%{?dist}
Summary: PHP library containing PDF page formats and definitions
@@ -27,10 +27,22 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
BuildArch: noarch
%if %{with_tests}
# For tests
-BuildRequires: php-composer(phpunit/phpunit)
+%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
+%global phpunit %{_bindir}/phpunit7
+%else
+%global phpunit %{_bindir}/phpunit
+%endif
+BuildRequires: %{phpunit}
BuildRequires: php(language) >= 5.4
-BuildRequires: php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 1.4.3
-BuildRequires: php-composer(%{c_vendor}/tc-lib-color) >= 1.12.1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(%{c_vendor}/tc-lib-color) >= 1.12.1 with php-composer(%{c_vendor}/tc-lib-color) < 2)
+BuildRequires: (php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 1.5.2 with php-composer(%{c_vendor}/tc-lib-pdf-encrypt) < 2)
+%else
+BuildRequires: php-composer(%{c_vendor}/tc-lib-color) < 2
+BuildRequires: php-composer(%{c_vendor}/tc-lib-color) >= 1.12.1
+BuildRequires: php-composer(%{c_vendor}/tc-lib-pdf-encrypt) < 2
+BuildRequires: php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 1.5.2
+%endif
BuildRequires: php-date
BuildRequires: php-zlib
%endif
@@ -44,10 +56,15 @@ BuildRequires: php-zlib
Requires: php(language) >= 5.4
Requires: php-date
Requires: php-zlib
-Requires: php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 1.4.3
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(%{c_vendor}/tc-lib-color) >= 1.12.6 with php-composer(%{c_vendor}/tc-lib-color) < 2)
+Requires: (php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 1.5.2 with php-composer(%{c_vendor}/tc-lib-pdf-encrypt) < 2)
+%else
+Requires: php-composer(%{c_vendor}/tc-lib-color) < 2
+Requires: php-composer(%{c_vendor}/tc-lib-color) >= 1.12.6
Requires: php-composer(%{c_vendor}/tc-lib-pdf-encrypt) < 2
-Requires: php-composer(%{c_vendor}/tc-lib-color) >= 1.12.1
-Requires: php-composer(%{c_vendor}/tc-lib-color) < 2
+Requires: php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 1.5.2
+%endif
# From phpcompatinfo report for version 2.0.1
# None
@@ -91,10 +108,10 @@ require '%{php_project}/../../Color/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" "php70 %{_bindir}/phpunit6" php71 php72; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit6} --no-coverage --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit7} --no-coverage --verbose || ret=1
fi
done
exit $ret
@@ -112,6 +129,11 @@ exit $ret
%changelog
+* Mon May 14 2018 Remi Collet <remi@remirepo.net> - 2.4.6-1
+- update to 2.4.6 (no change)
+- switch to phpunit7
+- use range dependencies
+
* Tue Jan 2 2018 Remi Collet <remi@remirepo.net> - 2.4.4-1
- Update to 2.4.4