summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-01-02 09:54:50 +0100
committerRemi Collet <remi@remirepo.net>2018-01-02 09:54:50 +0100
commitfd39bf1bfc88e51c423fc5cd9a2c0412d2a7dec6 (patch)
treeabe90d91df54c765507555b51db9952029beb83f
parent63afdca957614fed3e88535e4278f9a2302295b9 (diff)
v2.4.4
-rw-r--r--composer.json85
-rw-r--r--php-tecnickcom-tc-lib-pdf-page.spec21
2 files changed, 50 insertions, 56 deletions
diff --git a/composer.json b/composer.json
index 0ae422e..fce1260 100644
--- a/composer.json
+++ b/composer.json
@@ -1,47 +1,42 @@
{
- "name": "tecnickcom/tc-lib-pdf-page",
- "description": "PHP library containing PDF page formats and definitions",
- "type": "library",
- "homepage": "http://www.tecnick.com",
- "license": "LGPL-3.0",
- "keywords": ["tc-lib-pdf-page", "PDF", "page", "format"],
- "authors": [
- {
- "name": "Nicola Asuni",
- "email": "info@tecnick.com",
- "role": "lead"
- }
- ],
- "require": {
- "php": ">=5.4",
- "ext-date": "*",
- "ext-zlib": "*",
- "tecnickcom/tc-lib-pdf-encrypt": "^1.5.2",
- "tecnickcom/tc-lib-color": "^1.12.6"
- },
- "require-dev": {
- "apigen/apigen" : "^4.1.2",
- "bartlett/php-compatinfo" : "^5.0.4",
- "pdepend/pdepend" : "^2.5.0",
- "phploc/phploc" : "^2.1.5 || ^3.0.1",
- "phpmd/phpmd" : "^2.6.0",
- "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.0",
- "sebastian/phpcpd" : "^2.0.4 || 3.0.0",
- "squizlabs/php_codesniffer": "^2.8.0 || ^3.0.0"
- },
- "autoload": {
- "psr-4":{
- "Com\\Tecnick\\Pdf\\Page\\": "src"
- }
- },
- "repositories": [
- {
- "type": "vcs",
- "url": "git@github.com:tecnickcom/tc-lib-pdf-encrypt.git"
- },
- {
- "type": "vcs",
- "url": "git@github.com:tecnickcom/tc-lib-color.git"
- }
- ]
+ "name": "tecnickcom/tc-lib-pdf-page",
+ "description": "PHP library containing PDF page formats and definitions",
+ "type": "library",
+ "homepage": "http://www.tecnick.com",
+ "license": "LGPL-3.0",
+ "keywords": [
+ "tc-lib-pdf-page",
+ "PDF",
+ "page",
+ "format"
+ ],
+ "authors": [
+ {
+ "name": "Nicola Asuni",
+ "email": "info@tecnick.com",
+ "role": "lead"
+ }
+ ],
+ "require": {
+ "php": ">=5.4",
+ "ext-date": "*",
+ "ext-zlib": "*",
+ "tecnickcom/tc-lib-color": "^1.12.7",
+ "tecnickcom/tc-lib-pdf-encrypt": "^1.5.4"
+ },
+ "require-dev": {
+ "apigen/apigen": "^4.1.2",
+ "bartlett/php-compatinfo": "^5.0.4",
+ "pdepend/pdepend": "^2.5.0",
+ "phploc/phploc": "^2.1.5 || ^3.0.1",
+ "phpmd/phpmd": "^2.6.0",
+ "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.0",
+ "sebastian/phpcpd": "^2.0.4 || 3.0.0",
+ "squizlabs/php_codesniffer": "^2.8.0 || ^3.0.0"
+ },
+ "autoload": {
+ "psr-4": {
+ "Com\\Tecnick\\Pdf\\Page\\": "src"
+ }
+ }
}
diff --git a/php-tecnickcom-tc-lib-pdf-page.spec b/php-tecnickcom-tc-lib-pdf-page.spec
index 7045bf6..cd30090 100644
--- a/php-tecnickcom-tc-lib-pdf-page.spec
+++ b/php-tecnickcom-tc-lib-pdf-page.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-tecnickcom-tc-lib-pdf-page
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit c86292d32b66652345ae7dcf9172d383c1d3d465
+%global gh_commit 43e0e6f95e4b64e85d068b03df4e0739f842507b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.4.3
+Version: 2.4.4
Release: 1%{?dist}
Summary: PHP library containing PDF page formats and definitions
@@ -91,14 +91,10 @@ require '%{php_project}/../../Color/autoload.php';
EOF
ret=0
-for cmd in php56 php; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit --no-coverage --verbose || ret=1
- fi
-done
-for cmd in php70 php71 php72; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit6 --no-coverage --verbose || ret=1
+for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit6} --no-coverage --verbose || ret=1
fi
done
exit $ret
@@ -116,6 +112,9 @@ exit $ret
%changelog
+* Tue Jan 2 2018 Remi Collet <remi@remirepo.net> - 2.4.4-1
+- Update to 2.4.4
+
* Mon May 8 2017 Remi Collet <remi@remirepo.net> - 2.4.3-1
- Update to 2.4.3