summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-11-22 13:44:19 +0100
committerRemi Collet <remi@php.net>2023-11-22 13:44:19 +0100
commit55d0e137181b5e32c7fcc3da5c5b94f0c1abb404 (patch)
tree2dc366d6b4e34f53488a892017ebfa386efec4b7
parent9008c2d8b5f0bdf16b0290e898825a3e1447ff47 (diff)
update to 2.0.7
raise dependency on PHP 8
-rw-r--r--composer.json6
-rw-r--r--php-tecnickcom-tc-lib-pdf-filter.spec18
2 files changed, 14 insertions, 10 deletions
diff --git a/composer.json b/composer.json
index 5374692..45fe697 100644
--- a/composer.json
+++ b/composer.json
@@ -19,15 +19,15 @@
}
],
"require": {
- "php": ">=5.4",
+ "php": ">=8.0",
"ext-zlib": "*",
"ext-pcre": "*"
},
"require-dev": {
"pdepend/pdepend": "2.13.0",
"phpmd/phpmd": "2.13.0",
- "phpunit/phpunit": "10.1.2 || 9.6.7 || 8.5.31 || 7.5.20 || 6.5.14 || 5.7.27 || 4.8.36",
- "squizlabs/php_codesniffer": "3.7.2 || 2.9.2"
+ "phpunit/phpunit": "10.1.2 || 9.6.13",
+ "squizlabs/php_codesniffer": "3.7.2"
},
"autoload": {
"psr-4": {
diff --git a/php-tecnickcom-tc-lib-pdf-filter.spec b/php-tecnickcom-tc-lib-pdf-filter.spec
index 6f20016..683d1cd 100644
--- a/php-tecnickcom-tc-lib-pdf-filter.spec
+++ b/php-tecnickcom-tc-lib-pdf-filter.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit a78c82455533c79cddf52717da0dc9094346d847
+%global gh_commit 70f553933dc1071a530a4d690d802ae47655b409
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.4.37
+Version: 2.0.7
Release: 1%{?dist}
Summary: PHP library to decode PDF compression and encryption filters
@@ -29,23 +29,23 @@ BuildArch: noarch
# remirepo:1
%if 0%{?fedora} >= 37 || 0%{?rhel} >= 10
%global phpunit %{_bindir}/phpunit10
-BuildRequires: phpunit10
+BuildRequires: phpunit10 >= 10.1.2
# remirepo:4
%else
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.5.27
+BuildRequires: phpunit9 >= 9.6.13
%endif
-BuildRequires: php(language) >= 5.4
+BuildRequires: php(language) >= 8.0
Requires: php-pcre
Requires: php-zlib
%endif
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
-# "php": ">=5.4",
+# "php": ">=8.0",
# "ext-zlib": "*",
# "ext-pcre": "*"
-Requires: php(language) >= 5.4
+Requires: php(language) >= 8.0
Requires: php-pcre
Requires: php-zlib
# From phpcompatinfo report for version 1.3.4
@@ -117,6 +117,10 @@ exit $ret
%changelog
+* Wed Nov 22 2023 Remi Collet <remi@remirepo.net> - 2.0.7-1
+- update to 2.0.7
+- raise dependency on PHP 8
+
* Mon Oct 23 2023 Remi Collet <remi@remirepo.net> - 1.4.37-1
- update to 1.4.37 (no change)