summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-10-23 13:55:42 +0200
committerRemi Collet <remi@php.net>2023-10-23 13:55:42 +0200
commit9008c2d8b5f0bdf16b0290e898825a3e1447ff47 (patch)
tree27151380b84320f524d951b392cdc65798b880e8
parentd95af2c7df43dc0b7bb261810bfa6e4ba8929ff2 (diff)
update to 1.4.37 (no change)
-rw-r--r--php-tecnickcom-tc-lib-pdf-filter.spec24
1 files changed, 18 insertions, 6 deletions
diff --git a/php-tecnickcom-tc-lib-pdf-filter.spec b/php-tecnickcom-tc-lib-pdf-filter.spec
index d282cf3..6f20016 100644
--- a/php-tecnickcom-tc-lib-pdf-filter.spec
+++ b/php-tecnickcom-tc-lib-pdf-filter.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit ef0b81bc5cd3ceaf60fd14873e7bfc60bbfca3be
+%global gh_commit a78c82455533c79cddf52717da0dc9094346d847
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.4.35
+Version: 1.4.37
Release: 1%{?dist}
Summary: PHP library to decode PDF compression and encryption filters
@@ -26,8 +26,15 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
BuildArch: noarch
%if %{with_tests}
# For tests
+# remirepo:1
+%if 0%{?fedora} >= 37 || 0%{?rhel} >= 10
+%global phpunit %{_bindir}/phpunit10
+BuildRequires: phpunit10
+# remirepo:4
+%else
%global phpunit %{_bindir}/phpunit9
BuildRequires: phpunit9 >= 9.5.27
+%endif
BuildRequires: php(language) >= 5.4
Requires: php-pcre
Requires: php-zlib
@@ -83,11 +90,12 @@ require '%{buildroot}%{php_project}/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php80 %{phpunit}" php81 php82 php83; do
+for cmdarg in php "php80 %{_bindir}/phpunit9" php81 php82 php83; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit10} --migrate-configuration || :
- $1 ${2:-%{_bindir}/phpunit10} --no-coverage || ret=1
+ cp phpunit.xml.dist phpunit.xml
+ $1 ${2:-%{phpunit}} --migrate-configuration || :
+ $1 ${2:-%{phpunit}} --no-coverage || ret=1
fi
done
exit $ret
@@ -97,10 +105,11 @@ exit $ret
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc composer.json
-%doc README.md
+%doc *.md
%dir %{_datadir}/php/Com
%dir %{_datadir}/php/Com/Tecnick
%dir %{_datadir}/php/Com/Tecnick/Pdf
@@ -108,6 +117,9 @@ exit $ret
%changelog
+* Mon Oct 23 2023 Remi Collet <remi@remirepo.net> - 1.4.37-1
+- update to 1.4.37 (no change)
+
* Thu Oct 12 2023 Remi Collet <remi@remirepo.net> - 1.4.35-1
- update to 1.4.35