summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-11-28 12:40:04 +0100
committerRemi Collet <remi@php.net>2023-11-28 12:40:04 +0100
commitedcad9240995f797d157d8f567c300113e34745e (patch)
tree8a579a67d142238755fe77743d1dfc1a1a55012b
parenta2f366d49bfd61155a001c0db768ef0f82a4494d (diff)
use legacy openssl config for tests
-rw-r--r--php-tecnickcom-tc-lib-pdf-encrypt.spec20
1 files changed, 12 insertions, 8 deletions
diff --git a/php-tecnickcom-tc-lib-pdf-encrypt.spec b/php-tecnickcom-tc-lib-pdf-encrypt.spec
index c128632..0be1d8d 100644
--- a/php-tecnickcom-tc-lib-pdf-encrypt.spec
+++ b/php-tecnickcom-tc-lib-pdf-encrypt.spec
@@ -16,7 +16,7 @@
Name: php-%{gh_owner}-%{gh_project}
Version: 2.0.7
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: PHP library to encrypt data for PDF
License: LGPL-3.0-or-later
@@ -45,7 +45,7 @@ BuildRequires: phpunit9 >= 9.6.13
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
-# "php": ">=5.4",
+# "php": ">=8.0",
# "ext-date": "*",
# "ext-hash": "*",
# "ext-openssl": "*",
@@ -101,16 +101,17 @@ require '%{buildroot}%{php_project}/autoload.php';
EOF
ret=0
-VER=$(php -r 'echo (OPENSSL_VERSION_NUMBER>>28);')
-if [ $VER -ge 3 ]; then
- FILTER="--filter '^((?!(testGetFormattedDate|testGetPdfEncryptionObjTwo|testEncrypt128|testEncrypt40|testEncryptPubThree|testEncryptPubNoP|testEncryptModZeroPub|testGetPdfEncryptionObjThreePub|testGetPdfEncryptionObjOnePub|testGetEncryptionData|testGetObjectKey|testEncryptStringEnabled|testEscapeDataStringEnabled|testGetPdfEncryptionObjOne|testGetPdfEncryptionObjZero)).)*$'"
-fi
-for cmdarg in php "php80 %{_bindir}/phpunit9" php81 php82 php83; do
+# https://github.com/tecnickcom/tc-lib-pdf-encrypt/issues/12
+# allow legacy cypher methods (RC4...) for test
+sed -e 's/^##//' /etc/pki/tls/openssl.cnf >openssl.cnf
+export OPENSSL_CONF=$PWD/openssl.cnf
+
+for cmdarg in php php81 php82 php83; do
if which $cmdarg; then
set $cmdarg
cp phpunit.xml.dist phpunit.xml
$1 ${2:-%{phpunit}} --migrate-configuration || :
- $1 ${2:-%{phpunit}} $FILTER --no-coverage || ret=1
+ $1 ${2:-%{phpunit}} --no-coverage || ret=1
fi
done
exit $ret
@@ -132,6 +133,9 @@ exit $ret
%changelog
+* Tue Nov 28 2023 Remi Collet <remi@remirepo.net> - 2.0.7-2
+- use legacy openssl config for tests
+
* Wed Nov 22 2023 Remi Collet <remi@remirepo.net> - 2.0.7-1
- update to 2.0.7
- raise dependency on PHP 8