summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-11-22 13:39:56 +0100
committerRemi Collet <remi@php.net>2023-11-22 13:39:56 +0100
commita2f366d49bfd61155a001c0db768ef0f82a4494d (patch)
treebd5c1ee71fa1abfad7be168d397c26959e482351
parentcaf979be90af2b6697793d561807bc676a96f0e1 (diff)
update to 2.0.7
raise dependency on PHP 8
-rw-r--r--composer.json6
-rw-r--r--php-tecnickcom-tc-lib-pdf-encrypt.spec18
2 files changed, 14 insertions, 10 deletions
diff --git a/composer.json b/composer.json
index 04bba56..7f5952f 100644
--- a/composer.json
+++ b/composer.json
@@ -20,7 +20,7 @@
}
],
"require": {
- "php": ">=5.4",
+ "php": ">=8.0",
"ext-date": "*",
"ext-hash": "*",
"ext-openssl": "*",
@@ -32,8 +32,8 @@
"require-dev": {
"pdepend/pdepend": "2.13.0",
"phpmd/phpmd": "2.13.0",
- "phpunit/phpunit": "10.1.2 || 9.6.7 || 8.5.31 || 7.5.20 || 6.5.14 || 5.7.27 || 4.8.36",
- "squizlabs/php_codesniffer": "3.7.2 || 2.9.2"
+ "phpunit/phpunit": "10.1.2 || 9.6.13",
+ "squizlabs/php_codesniffer": "3.7.2"
},
"autoload": {
"psr-4": {
diff --git a/php-tecnickcom-tc-lib-pdf-encrypt.spec b/php-tecnickcom-tc-lib-pdf-encrypt.spec
index 23a30dd..c128632 100644
--- a/php-tecnickcom-tc-lib-pdf-encrypt.spec
+++ b/php-tecnickcom-tc-lib-pdf-encrypt.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit b42d1fd2c7b0d6f42268d44690269bdf0ae2a700
+%global gh_commit e8e5570b4bb7c83baa6fc7e663d9a93cf2b1d052
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.6.35
+Version: 2.0.7
Release: 1%{?dist}
Summary: PHP library to encrypt data for PDF
@@ -26,7 +26,7 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
BuildArch: noarch
%if %{with_tests}
# For tests
-BuildRequires: php(language) >= 5.4
+BuildRequires: php(language) >= 8.0
BuildRequires: php-date
BuildRequires: php-hash
BuildRequires: php-openssl
@@ -35,11 +35,11 @@ BuildRequires: php-posix
# remirepo:1
%if 0%{?fedora} >= 37 || 0%{?rhel} >= 10
%global phpunit %{_bindir}/phpunit10
-BuildRequires: phpunit10
+BuildRequires: phpunit10 >= 10.1.2
# remirepo:4
%else
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.5.27
+BuildRequires: phpunit9 >= 9.6.13
%endif
%endif
BuildRequires: php-fedora-autoloader-devel
@@ -50,7 +50,7 @@ BuildRequires: php-fedora-autoloader-devel
# "ext-hash": "*",
# "ext-openssl": "*",
# "ext-pcre": "*",
-Requires: php(language) >= 5.4
+Requires: php(language) >= 8.0
Requires: php-date
Requires: php-hash
Requires: php-openssl
@@ -103,7 +103,7 @@ EOF
ret=0
VER=$(php -r 'echo (OPENSSL_VERSION_NUMBER>>28);')
if [ $VER -ge 3 ]; then
- FILTER="--filter '^((?!(testEncryptPubThree|testEncryptPubNoP|testEncryptModZeroPub|testGetPdfEncryptionObjThreePub|testGetPdfEncryptionObjOnePub|testGetEncryptionData|testGetObjectKey|testEncryptStringEnabled|testEscapeDataStringEnabled|testGetPdfEncryptionObjOne|testGetPdfEncryptionObjZero)).)*$'"
+ FILTER="--filter '^((?!(testGetFormattedDate|testGetPdfEncryptionObjTwo|testEncrypt128|testEncrypt40|testEncryptPubThree|testEncryptPubNoP|testEncryptModZeroPub|testGetPdfEncryptionObjThreePub|testGetPdfEncryptionObjOnePub|testGetEncryptionData|testGetObjectKey|testEncryptStringEnabled|testEscapeDataStringEnabled|testGetPdfEncryptionObjOne|testGetPdfEncryptionObjZero)).)*$'"
fi
for cmdarg in php "php80 %{_bindir}/phpunit9" php81 php82 php83; do
if which $cmdarg; then
@@ -132,6 +132,10 @@ exit $ret
%changelog
+* Wed Nov 22 2023 Remi Collet <remi@remirepo.net> - 2.0.7-1
+- update to 2.0.7
+- raise dependency on PHP 8
+
* Mon Oct 23 2023 Remi Collet <remi@remirepo.net> - 1.6.35-1
- update to 1.6.35 (no change)