summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-05-14 06:57:28 +0200
committerRemi Collet <remi@remirepo.net>2018-05-14 06:57:28 +0200
commit8bd2a7820156c6908d49592e77832e73fe714829 (patch)
treeb59728165655789d7a471b415b8eab82984eaa49
parent6bce0587e8d250f2e3e35a6d2efc06ecf722a00b (diff)
update to 1.6.7 (no change)
switch to phpunit7
-rw-r--r--composer.json12
-rw-r--r--php-tecnickcom-tc-lib-file.spec16
2 files changed, 16 insertions, 12 deletions
diff --git a/composer.json b/composer.json
index bd065ba..506825a 100644
--- a/composer.json
+++ b/composer.json
@@ -28,13 +28,13 @@
},
"require-dev": {
"apigen/apigen": "^4.1.2",
- "bartlett/php-compatinfo": "^5.0.4",
- "pdepend/pdepend": "^2.5.0",
- "phploc/phploc": "^2.1.5 || ^3.0.1",
+ "bartlett/php-compatinfo": "^5.0.10 || ^5.0.12",
+ "pdepend/pdepend": "^2.5.2",
+ "phploc/phploc": "^2.1 || ^3.0 || ^4.0",
"phpmd/phpmd": "^2.6.0",
- "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.0",
- "sebastian/phpcpd": "^2.0.4 || 3.0.0",
- "squizlabs/php_codesniffer": "^2.8.0 || ^3.0.0"
+ "phpunit/phpunit": "^4.8 || ^5.7 || ^6.5 || ^7.1",
+ "sebastian/phpcpd": "^2.0 || ^3.0 || ^4.0",
+ "squizlabs/php_codesniffer": "^2.8.0 || ^3.2.0"
},
"autoload": {
"psr-4": {
diff --git a/php-tecnickcom-tc-lib-file.spec b/php-tecnickcom-tc-lib-file.spec
index 67a826e..7de1d7c 100644
--- a/php-tecnickcom-tc-lib-file.spec
+++ b/php-tecnickcom-tc-lib-file.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit f373192e4e6f408633a0ffbb4b5eb2da0d33a24d
+%global gh_commit 5960cb38212f874b2176342a31aa16d2240a4163
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.6.6
+Version: 1.6.7
Release: 1%{?dist}
Summary: PHP library to read byte-level data from files
@@ -27,8 +27,8 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
BuildArch: noarch
%if %{with_tests}
# For tests
-%if 0%{?fedora} >= 26
-%global phpunit %{_bindir}/phpunit6
+%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
+%global phpunit %{_bindir}/phpunit7
%else
%global phpunit %{_bindir}/phpunit
%endif
@@ -89,10 +89,10 @@ EOF
sed -i 's:src:File:g' -i test/DirTest.php
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" "php70 %{_bindir}/phpunit6" php71 php72; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit6} --no-coverage --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit7} --no-coverage --verbose || ret=1
fi
done
exit $ret
@@ -112,6 +112,10 @@ exit $ret
%changelog
+* Mon May 14 2018 Remi Collet <remi@remirepo.net> - 1.6.7-1
+- update to 1.6.7 (no change)
+- switch to phpunit7
+
* Tue Jan 2 2018 Remi Collet <remi@remirepo.net> - 1.6.6-1
- Update to 1.6.6 (no change)