summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-01-02 09:21:20 +0100
committerRemi Collet <remi@remirepo.net>2018-01-02 09:21:20 +0100
commita165c332cd4b84a9542de2346f6cabae673b5e86 (patch)
tree5af3ed135d606b8d5f03f4e63d4d86caf50e5005
parentafbb4bc2529800d021fcf1a6df87cf187b24b66e (diff)
v1.12.8 (no change)
-rw-r--r--.gitignore8
-rw-r--r--composer.json75
-rw-r--r--php-tecnickcom-tc-lib-color.spec17
3 files changed, 59 insertions, 41 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/composer.json b/composer.json
index e8f4f9c..9646b62 100644
--- a/composer.json
+++ b/composer.json
@@ -1,34 +1,47 @@
{
- "name": "tecnickcom/tc-lib-color",
- "description": "PHP library to manipulate various color representations",
- "type": "library",
- "homepage": "http://www.tecnick.com",
- "license": "LGPL-3.0",
- "keywords": ["tc-lib-color", "color", "colors", "colour", "colours", "javascript", "web", "rgb", "rgba", "cmyk", "hsl", "hsla"],
- "authors": [
- {
- "name": "Nicola Asuni",
- "email": "info@tecnick.com",
- "role": "lead"
- }
- ],
- "require": {
- "php": ">=5.4",
- "ext-pcre": "*"
- },
- "require-dev": {
- "apigen/apigen" : "^4.1.2",
- "bartlett/php-compatinfo" : "^5.0.4",
- "pdepend/pdepend" : "^2.5.0",
- "phploc/phploc" : "^2.1.5 || ^3.0.1",
- "phpmd/phpmd" : "^2.6.0",
- "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.0",
- "sebastian/phpcpd" : "^2.0.4 || 3.0.0",
- "squizlabs/php_codesniffer": "^2.8.0 || ^3.0.0"
- },
- "autoload": {
- "psr-4":{
- "Com\\Tecnick\\Color\\": "src"
- }
+ "name": "tecnickcom/tc-lib-color",
+ "description": "PHP library to manipulate various color representations",
+ "type": "library",
+ "homepage": "http://www.tecnick.com",
+ "license": "LGPL-3.0",
+ "keywords": [
+ "tc-lib-color",
+ "color",
+ "colors",
+ "colour",
+ "colours",
+ "javascript",
+ "web",
+ "rgb",
+ "rgba",
+ "cmyk",
+ "hsl",
+ "hsla"
+ ],
+ "authors": [
+ {
+ "name": "Nicola Asuni",
+ "email": "info@tecnick.com",
+ "role": "lead"
}
+ ],
+ "require": {
+ "php": ">=5.4",
+ "ext-pcre": "*"
+ },
+ "require-dev": {
+ "apigen/apigen": "^4.1.2",
+ "bartlett/php-compatinfo": "^5.0.4",
+ "pdepend/pdepend": "^2.5.0",
+ "phploc/phploc": "^2.1.5 || ^3.0.1",
+ "phpmd/phpmd": "^2.6.0",
+ "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.0",
+ "sebastian/phpcpd": "^2.0.4 || 3.0.0",
+ "squizlabs/php_codesniffer": "^2.8.0 || ^3.0.0"
+ },
+ "autoload": {
+ "psr-4": {
+ "Com\\Tecnick\\Color\\": "src"
+ }
+ }
}
diff --git a/php-tecnickcom-tc-lib-color.spec b/php-tecnickcom-tc-lib-color.spec
index c383c72..908fdbc 100644
--- a/php-tecnickcom-tc-lib-color.spec
+++ b/php-tecnickcom-tc-lib-color.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 8921acc8e9c26bdc32c9b08989d42e428af6c660
+%global gh_commit 1d1f9fbb03b6441501326b0ebc41b15dfd058e7b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.12.6
+Version: 1.12.8
Release: 1%{?dist}
Summary: PHP library to manipulate various color representations
@@ -24,7 +24,6 @@ License: LGPLv3+
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{?gh_short}.tar.gz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
%if %{with_tests}
# For tests
@@ -76,7 +75,6 @@ sed -e 's:^require:////require:' \
%install
-rm -rf %{buildroot}
mkdir -p $(dirname %{buildroot}%{php_project})
cp -pr src %{buildroot}%{php_project}
cp -p resources/autoload.php \
@@ -96,7 +94,8 @@ for cmd in "php %{phpunit}" \
"php56 %{_bindir}/phpunit" \
"php70 %{_bindir}/phpunit" \
"php70 %{_bindir}/phpunit6" \
- "php71 %{_bindir}/phpunit6"; do
+ "php71 %{_bindir}/phpunit6" \
+ "php72 %{_bindir}/phpunit6"; do
if which $cmd; then
$cmd --no-coverage --verbose || ret=1
fi
@@ -107,12 +106,7 @@ exit $ret
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc composer.json
@@ -123,6 +117,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Jan 2 2018 Remi Collet <remi@remirepo.net> - 1.12.8-1
+- Update to 1.12.8 (no change)
+
* Sun Feb 12 2017 Remi Collet <remi@fedoraproject.org> - 1.12.6-1
- update to 1.12.6 (no change)
- use phpunit6 on F26+