summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-03-13 15:15:11 +0100
committerRemi Collet <fedora@famillecollet.com>2017-03-13 15:15:11 +0100
commitafbb4bc2529800d021fcf1a6df87cf187b24b66e (patch)
tree6b8505b5697ecd7bfb55179d16616a863f8f0ffa
parent224ec7b098d489ca8fbf07807f5b73ea61b1ba25 (diff)
wip
-rw-r--r--php-tecnickcom-tc-lib-color.spec21
1 files changed, 13 insertions, 8 deletions
diff --git a/php-tecnickcom-tc-lib-color.spec b/php-tecnickcom-tc-lib-color.spec
index caa1413..c383c72 100644
--- a/php-tecnickcom-tc-lib-color.spec
+++ b/php-tecnickcom-tc-lib-color.spec
@@ -28,7 +28,12 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
%if %{with_tests}
# For tests
-BuildRequires: php-composer(phpunit/phpunit)
+%if 0%{?fedora} >= 26
+%global phpunit %{_bindir}/phpunit6
+%else
+%global phpunit %{_bindir}/phpunit
+%endif
+BuildRequires: %{phpunit}
BuildRequires: php(language) >= 5.4
Requires: php-pcre
%endif
@@ -87,14 +92,13 @@ require '%{buildroot}%{php_project}/autoload.php';
EOF
ret=0
-for cmd in php56 php; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit --verbose || ret=1
- fi
-done
-for cmd in php70 php71; do
+for cmd in "php %{phpunit}" \
+ "php56 %{_bindir}/phpunit" \
+ "php70 %{_bindir}/phpunit" \
+ "php70 %{_bindir}/phpunit6" \
+ "php71 %{_bindir}/phpunit6"; do
if which $cmd; then
- $cmd %{_bindir}/phpunit6 --verbose || ret=1
+ $cmd --no-coverage --verbose || ret=1
fi
done
exit $ret
@@ -121,6 +125,7 @@ rm -rf %{buildroot}
%changelog
* Sun Feb 12 2017 Remi Collet <remi@fedoraproject.org> - 1.12.6-1
- update to 1.12.6 (no change)
+- use phpunit6 on F26+
* Mon Feb 6 2017 Remi Collet <remi@fedoraproject.org> - 1.12.4-1
- update to 1.12.4 (no change)