summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-01-02 09:47:18 +0100
committerRemi Collet <remi@remirepo.net>2018-01-02 09:47:18 +0100
commit78e820b83d4f4c67deb9fda147a6ff1ca1a26ec9 (patch)
treea8bb8099b3e628ad8df85a4e7c192067dabf3bf3
parenta165c332cd4b84a9542de2346f6cabae673b5e86 (diff)
simplify
-rw-r--r--php-tecnickcom-tc-lib-color.spec14
1 files changed, 5 insertions, 9 deletions
diff --git a/php-tecnickcom-tc-lib-color.spec b/php-tecnickcom-tc-lib-color.spec
index 908fdbc..15ebd70 100644
--- a/php-tecnickcom-tc-lib-color.spec
+++ b/php-tecnickcom-tc-lib-color.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-tecnickcom-tc-lib-color
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -90,14 +90,10 @@ require '%{buildroot}%{php_project}/autoload.php';
EOF
ret=0
-for cmd in "php %{phpunit}" \
- "php56 %{_bindir}/phpunit" \
- "php70 %{_bindir}/phpunit" \
- "php70 %{_bindir}/phpunit6" \
- "php71 %{_bindir}/phpunit6" \
- "php72 %{_bindir}/phpunit6"; do
- if which $cmd; then
- $cmd --no-coverage --verbose || ret=1
+for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit6} --no-coverage --verbose || ret=1
fi
done
exit $ret