summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-07-01 16:45:44 +0200
committerRemi Collet <fedora@famillecollet.com>2015-07-01 16:45:44 +0200
commit0cd7e7a116d00a4728f7d343c5c35c31827e8de9 (patch)
tree272565d6be843254fd3b80395585015b575dfacb
parent26952d6d5ebac8a27a29ec6437572257e5491a79 (diff)
php-tecnickcom-tc-lib-barcode: fix for php < 5.5
-rw-r--r--php-tecnickcom-tc-lib-barcode-pr2.patch22
-rw-r--r--php-tecnickcom-tc-lib-barcode.spec9
2 files changed, 30 insertions, 1 deletions
diff --git a/php-tecnickcom-tc-lib-barcode-pr2.patch b/php-tecnickcom-tc-lib-barcode-pr2.patch
new file mode 100644
index 0000000..4116301
--- /dev/null
+++ b/php-tecnickcom-tc-lib-barcode-pr2.patch
@@ -0,0 +1,22 @@
+From 1421aa08b9705ebfbef4b6cbbd3575483279a081 Mon Sep 17 00:00:00 2001
+From: Remi Collet <fedora@famillecollet.com>
+Date: Wed, 1 Jul 2015 16:41:43 +0200
+Subject: [PATCH] restore php < 5.5 compatibility, fix #1
+
+---
+ src/Type/Square/QrCode.php | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/Type/Square/QrCode.php b/src/Type/Square/QrCode.php
+index 59da935..12458fc 100644
+--- a/src/Type/Square/QrCode.php
++++ b/src/Type/Square/QrCode.php
+@@ -108,7 +108,7 @@ protected function setParameters()
+ if (!isset($this->params[3])) {
+ $this->params[3] = 1;
+ }
+- $this->case_sensitive = boolval($this->params[3]);
++ $this->case_sensitive = ($this->params[3] ? true : false);
+ }
+
+ /**
diff --git a/php-tecnickcom-tc-lib-barcode.spec b/php-tecnickcom-tc-lib-barcode.spec
index 6c74676..c8f935c 100644
--- a/php-tecnickcom-tc-lib-barcode.spec
+++ b/php-tecnickcom-tc-lib-barcode.spec
@@ -25,6 +25,9 @@ License: LGPLv3+
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{?gh_short}.tar.gz
+# https://github.com/tecnickcom/tc-lib-barcode/pull/2 - php < 5.5 compat
+Patch0: %{name}-pr2.patch
+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
%if %{with_tests}
@@ -73,6 +76,8 @@ Optional dependency: php-pecl-imagick
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+%patch0 -p1
+
: Sanity check
grep -q '^%{version}$' VERSION
@@ -124,4 +129,6 @@ rm -rf %{buildroot}
%changelog
* Wed Jul 1 2015 Remi Collet <remi@fedoraproject.org> - 1.1.2-1
-- initial package, version 1.1.2 \ No newline at end of file
+- initial package, version 1.1.2
+- open https://github.com/tecnickcom/tc-lib-barcode/pull/2
+ PHP < 5.5 compatibility \ No newline at end of file