summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-07-01 16:19:10 +0200
committerRemi Collet <fedora@famillecollet.com>2015-07-01 16:19:10 +0200
commit26952d6d5ebac8a27a29ec6437572257e5491a79 (patch)
tree4068bcb2021c342db50b3f184158288149809192
php-tecnickcom-tc-lib-barcode: 1.1.2 - New package
-rw-r--r--Makefile4
-rw-r--r--php-tecnickcom-tc-lib-barcode.spec127
2 files changed, 131 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-tecnickcom-tc-lib-barcode.spec b/php-tecnickcom-tc-lib-barcode.spec
new file mode 100644
index 0000000..6c74676
--- /dev/null
+++ b/php-tecnickcom-tc-lib-barcode.spec
@@ -0,0 +1,127 @@
+# remirepo/fedora spec file for php-tecnickcom-tc-lib-barcode
+#
+# Copyright (c) 2015 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global gh_commit 1c92ea2f5d3ae5d2121da85522c6f053cf7bcfd1
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global c_vendor tecnick.com
+%global gh_owner tecnickcom
+%global gh_project tc-lib-barcode
+%global php_home %{_datadir}/php/Com/Tecnick
+%global php_project %{php_home}/Barcode
+%global with_tests 0%{!?_without_tests:1}
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 1.1.2
+Release: 1%{?dist}
+Summary: PHP library to manipulate various color representations
+
+Group: Development/Libraries
+License: LGPLv3+
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{?gh_short}.tar.gz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+%if %{with_tests}
+# For tests
+BuildRequires: %{_bindir}/phpunit
+BuildRequires: php(language) >= 5.3.3
+BuildRequires: php-composer(%{c_vendor}/tc-lib-color)
+BuildRequires: php-bcmath
+BuildRequires: php-date
+BuildRequires: php-gd
+BuildRequires: php-pcre
+# Optional but required for test
+BuildRequires: php-pecl-imagick
+%endif
+
+# From composer.json, "require": {
+# "php": ">=5.3.3"
+# "tecnick.com/tc-lib-color": "dev-master"
+Requires: php(language) >= 5.3.3
+Requires: php-composer(%{c_vendor}/tc-lib-color)
+# From phpcompatinfo report for version 1.1.2
+Requires: php-bcmath
+Requires: php-date
+Requires: php-gd
+Requires: php-pcre
+
+# Composer
+Provides: php-composer(%{c_vendor}/%{gh_project}) = %{version}
+# Upstream package name
+Provides: php-%{gh_project} = %{version}
+
+
+%description
+Provides tc-lib-barcode: PHP classes to generate linear and bidimensional
+barcodes: CODE 39, ANSI MH10.8M-1983, USD-3, 3 of 9, CODE 93, USS-93,
+Standard 2 of 5, Interleaved 2 of 5, CODE 128 A/B/C, 2 and 5 Digits
+UPC-Based Extension, EAN 8, EAN 13, UPC-A, UPC-E, MSI, POSTNET, PLANET,
+RMS4CC (Royal Mail 4-state Customer Code), CBC (Customer Bar Code),
+KIX (Klant index - Customer index), Intelligent Mail Barcode, Onecode,
+USPS-B-3200, CODABAR, CODE 11, PHARMACODE, PHARMACODE TWO-TRACKS, Datamatrix
+ECC200, QR-Code, PDF417.
+
+Optional dependency: php-pecl-imagick
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+: Sanity check
+grep -q '^%{version}$' VERSION
+
+: Fix the examples
+sed -e 's:^require:////require:' \
+ -e 's:^//require:require:' \
+ -i example/*php
+
+
+%build
+# Empty build section, most likely nothing required.
+
+
+%install
+rm -rf %{buildroot}
+mkdir -p %{buildroot}%{php_home}
+cp -pr src %{buildroot}%{php_project}
+cp -p resources/autoload.php \
+ %{buildroot}%{php_project}/autoload.php
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat <<EOF | tee vendor/autoload.php
+<?php
+require '%{buildroot}%{php_project}/autoload.php';
+require '%{php_home}/Color/autoload.php';
+EOF
+
+%{_bindir}/phpunit --verbose
+%else
+: Test suite disabled
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{!?_licensedir:%global license %%doc}
+%license LICENSE.TXT
+%doc composer.json
+%doc README.md example
+%{php_project}
+
+
+%changelog
+* Wed Jul 1 2015 Remi Collet <remi@fedoraproject.org> - 1.1.2-1
+- initial package, version 1.1.2 \ No newline at end of file