summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-02-12 17:16:40 +0100
committerRemi Collet <fedora@famillecollet.com>2017-02-12 17:16:40 +0100
commitf1ef54c499f1c634d90d6f634442aee908892b01 (patch)
tree020585c6b864992c2dd1a0a0f85dfd1ca8f00932
parentf25b17cd8cd612b4f234261c0518533c7d20e4bf (diff)
php-tecnickcom-tc-lib-unicode: 1.3.5
-rw-r--r--php-tecnickcom-tc-lib-unicode/composer.json16
-rw-r--r--php-tecnickcom-tc-lib-unicode/php-tecnickcom-tc-lib-unicode.spec16
2 files changed, 20 insertions, 12 deletions
diff --git a/php-tecnickcom-tc-lib-unicode/composer.json b/php-tecnickcom-tc-lib-unicode/composer.json
index 2c849e0..266b3d4 100644
--- a/php-tecnickcom-tc-lib-unicode/composer.json
+++ b/php-tecnickcom-tc-lib-unicode/composer.json
@@ -16,17 +16,17 @@
"php": ">=5.4",
"ext-mbstring": "*",
"ext-pcre": "*",
- "tecnickcom/tc-lib-unicode-data": "^1.6.3"
+ "tecnickcom/tc-lib-unicode-data": "^1.6.5"
},
"require-dev": {
"apigen/apigen" : "^4.1.2",
- "bartlett/php-compatinfo" : "^5.0.0",
- "pdepend/pdepend" : "^2.2.2",
- "phploc/phploc" : "^2.1.5|^3.0.0",
- "phpmd/phpmd" : "^2.3.2",
- "phpunit/phpunit": "4.8.19|^5.0.0",
- "sebastian/phpcpd" : "^2.0.2",
- "squizlabs/php_codesniffer": "^2.5.0|^3.0.0"
+ "bartlett/php-compatinfo" : "^5.0.4",
+ "pdepend/pdepend" : "^2.5.0",
+ "phploc/phploc" : "^2.1.5 || ^3.0.1",
+ "phpmd/phpmd" : "^2.6.0",
+ "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.0",
+ "sebastian/phpcpd" : "^2.0.4 || 3.0.0",
+ "squizlabs/php_codesniffer": "^2.8.0 || ^3.0.0"
},
"autoload": {
"psr-4":{
diff --git a/php-tecnickcom-tc-lib-unicode/php-tecnickcom-tc-lib-unicode.spec b/php-tecnickcom-tc-lib-unicode/php-tecnickcom-tc-lib-unicode.spec
index 46cfaf6..c81abcb 100644
--- a/php-tecnickcom-tc-lib-unicode/php-tecnickcom-tc-lib-unicode.spec
+++ b/php-tecnickcom-tc-lib-unicode/php-tecnickcom-tc-lib-unicode.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit d90a91626d60fd947a7b8a3618670b724cdcebef
+%global gh_commit e07e2f3c0f8391f8b13a24f32c9f3ec2edd4bef4
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.3.4
+Version: 1.3.5
Release: 1%{?dist}
Summary: PHP library containing Unicode methods
@@ -90,9 +90,14 @@ require '%{php_project}/Data/autoload.php';
EOF
ret=0
-for cmd in php56 php70 php71 php; do
+for cmd in php56 php; do
if which $cmd; then
- $cmd %{_bindir}/phpunit --verbose || ret=1
+ $cmd %{_bindir}/phpunit --no-coverage --verbose || ret=1
+ fi
+done
+for cmd in php70 php71; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit6 --no-coverage --verbose || ret=1
fi
done
exit $ret
@@ -115,6 +120,9 @@ rm -rf %{buildroot}
%changelog
+* Sun Feb 12 2017 Remi Collet <remi@remirepo.net> - 1.3.5-1
+- update to 1.3.5 (no change)
+
* Mon Feb 6 2017 Remi Collet <remi@remirepo.net> - 1.3.4-1
- update to 1.3.4 (no change)