summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-02-12 17:14:10 +0100
committerRemi Collet <fedora@famillecollet.com>2017-02-12 17:14:10 +0100
commitf25b17cd8cd612b4f234261c0518533c7d20e4bf (patch)
tree900d2d2c292b2871c20a3008ff28e10ea2d268ab
parent9645f608c40c55a3cf22dd5c45ef7f94a1de5c52 (diff)
php-tecnickcom-tc-lib-pdf-page: 2.4.2
-rw-r--r--php-tecnickcom-tc-lib-pdf-page/composer.json18
-rw-r--r--php-tecnickcom-tc-lib-pdf-page/php-tecnickcom-tc-lib-pdf-page.spec16
2 files changed, 21 insertions, 13 deletions
diff --git a/php-tecnickcom-tc-lib-pdf-page/composer.json b/php-tecnickcom-tc-lib-pdf-page/composer.json
index 4edabe7..0ae422e 100644
--- a/php-tecnickcom-tc-lib-pdf-page/composer.json
+++ b/php-tecnickcom-tc-lib-pdf-page/composer.json
@@ -16,18 +16,18 @@
"php": ">=5.4",
"ext-date": "*",
"ext-zlib": "*",
- "tecnickcom/tc-lib-pdf-encrypt": "^1.4.4",
- "tecnickcom/tc-lib-color": "^1.12.4"
+ "tecnickcom/tc-lib-pdf-encrypt": "^1.5.2",
+ "tecnickcom/tc-lib-color": "^1.12.6"
},
"require-dev": {
"apigen/apigen" : "^4.1.2",
- "bartlett/php-compatinfo" : "^5.0.0",
- "pdepend/pdepend" : "^2.2.2",
- "phploc/phploc" : "^2.1.5|^3.0.0",
- "phpmd/phpmd" : "^2.3.2",
- "phpunit/phpunit": "4.8.19|^5.0.0",
- "sebastian/phpcpd" : "^2.0.2",
- "squizlabs/php_codesniffer": "^2.5.0|^3.0.0"
+ "bartlett/php-compatinfo" : "^5.0.4",
+ "pdepend/pdepend" : "^2.5.0",
+ "phploc/phploc" : "^2.1.5 || ^3.0.1",
+ "phpmd/phpmd" : "^2.6.0",
+ "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.0",
+ "sebastian/phpcpd" : "^2.0.4 || 3.0.0",
+ "squizlabs/php_codesniffer": "^2.8.0 || ^3.0.0"
},
"autoload": {
"psr-4":{
diff --git a/php-tecnickcom-tc-lib-pdf-page/php-tecnickcom-tc-lib-pdf-page.spec b/php-tecnickcom-tc-lib-pdf-page/php-tecnickcom-tc-lib-pdf-page.spec
index 69f0d4f..9df36e9 100644
--- a/php-tecnickcom-tc-lib-pdf-page/php-tecnickcom-tc-lib-pdf-page.spec
+++ b/php-tecnickcom-tc-lib-pdf-page/php-tecnickcom-tc-lib-pdf-page.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit e62193cc9d415136514b9e7abf99c46abdc526cc
+%global gh_commit da4b7871ca1ddf5db103378dde23f3c747619689
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.4.1
+Version: 2.4.2
Release: 1%{?dist}
Summary: PHP library containing PDF page formats and definitions
@@ -93,9 +93,14 @@ require '%{php_project}/../../Color/autoload.php';
EOF
ret=0
-for cmd in php56 php70 php71 php; do
+for cmd in php56 php; do
if which $cmd; then
- $cmd %{_bindir}/phpunit --verbose || ret=1
+ $cmd %{_bindir}/phpunit --no-coverage --verbose || ret=1
+ fi
+done
+for cmd in php70 php71; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit6 --no-coverage --verbose || ret=1
fi
done
exit $ret
@@ -118,6 +123,9 @@ rm -rf %{buildroot}
%changelog
+* Sun Feb 12 2017 Remi Collet <remi@remirepo.net> - 2.4.2-1
+- update to 2.4.2
+
* Mon Feb 6 2017 Remi Collet <remi@remirepo.net> - 2.4.1-1
- update to 2.4.1