summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-02-12 17:04:59 +0100
committerRemi Collet <fedora@famillecollet.com>2017-02-12 17:04:59 +0100
commitd899d3d499985cb28de460159cb9f88d4117878c (patch)
treefda06d4325c26179dd42d08a4b69844aa50f37cc
parentbe17d5728a48d6c9ab4d0409f0014bceac232173 (diff)
php-tecnickcom-tc-lib-pdf-encrypt: 1.5.2
-rw-r--r--php-tecnickcom-tc-lib-pdf-encrypt/composer.json14
-rw-r--r--php-tecnickcom-tc-lib-pdf-encrypt/php-tecnickcom-tc-lib-pdf-encrypt.spec16
2 files changed, 19 insertions, 11 deletions
diff --git a/php-tecnickcom-tc-lib-pdf-encrypt/composer.json b/php-tecnickcom-tc-lib-pdf-encrypt/composer.json
index abc15a4..dba2ee0 100644
--- a/php-tecnickcom-tc-lib-pdf-encrypt/composer.json
+++ b/php-tecnickcom-tc-lib-pdf-encrypt/composer.json
@@ -22,13 +22,13 @@
},
"require-dev": {
"apigen/apigen" : "^4.1.2",
- "bartlett/php-compatinfo" : "^5.0.0",
- "pdepend/pdepend" : "^2.2.2",
- "phploc/phploc" : "^2.1.5|^3.0.0",
- "phpmd/phpmd" : "^2.3.2",
- "phpunit/phpunit": "4.8.19|^5.0.0",
- "sebastian/phpcpd" : "^2.0.2",
- "squizlabs/php_codesniffer": "^2.5.0|^3.0.0"
+ "bartlett/php-compatinfo" : "^5.0.4",
+ "pdepend/pdepend" : "^2.5.0",
+ "phploc/phploc" : "^2.1.5 || ^3.0.1",
+ "phpmd/phpmd" : "^2.6.0",
+ "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.0",
+ "sebastian/phpcpd" : "^2.0.4 || 3.0.0",
+ "squizlabs/php_codesniffer": "^2.8.0 || ^3.0.0"
},
"autoload": {
"psr-4":{
diff --git a/php-tecnickcom-tc-lib-pdf-encrypt/php-tecnickcom-tc-lib-pdf-encrypt.spec b/php-tecnickcom-tc-lib-pdf-encrypt/php-tecnickcom-tc-lib-pdf-encrypt.spec
index a1197d5..a3f2d98 100644
--- a/php-tecnickcom-tc-lib-pdf-encrypt/php-tecnickcom-tc-lib-pdf-encrypt.spec
+++ b/php-tecnickcom-tc-lib-pdf-encrypt/php-tecnickcom-tc-lib-pdf-encrypt.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 66db26ddb3d1a0204b9113dbc594750f4d5448ae
+%global gh_commit 0da81c1f2ec073781e1650bc64915d26ff19ebe9
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.5.0
+Version: 1.5.2
Release: 1%{?dist}
Summary: PHP library to encrypt data for PDF
@@ -94,9 +94,14 @@ require '%{buildroot}%{php_project}/autoload.php';
EOF
ret=0
-for cmd in php56 php70 php71 php; do
+for cmd in php56 php; do
if which $cmd; then
- $cmd %{_bindir}/phpunit --verbose || ret=1
+ $cmd %{_bindir}/phpunit --no-coverage --verbose || ret=1
+ fi
+done
+for cmd in php70 php71; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit6 --no-coverage --verbose || ret=1
fi
done
exit $ret
@@ -122,6 +127,9 @@ rm -rf %{buildroot}
%changelog
+* Sun Feb 12 2017 Remi Collet <remi@fedoraproject.org> - 1.5.2-1
+- update to 1.5.2 (no change)
+
* Wed Feb 8 2017 Remi Collet <remi@fedoraproject.org> - 1.5.0-1
- update to 1.5.0
- drop dependency on php-mcrypt