summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-02-12 17:04:41 +0100
committerRemi Collet <fedora@famillecollet.com>2017-02-12 17:04:41 +0100
commitbe17d5728a48d6c9ab4d0409f0014bceac232173 (patch)
tree00c99c7550a979de44aff700aa174bf21419d96b
parentce91d75fa5675612fa6330fc03c98e861b869ad6 (diff)
php-tecnickcom-tc-lib-file: 1.6.5
-rw-r--r--php-tecnickcom-tc-lib-file/composer.json14
-rw-r--r--php-tecnickcom-tc-lib-file/php-tecnickcom-tc-lib-file.spec16
2 files changed, 19 insertions, 11 deletions
diff --git a/php-tecnickcom-tc-lib-file/composer.json b/php-tecnickcom-tc-lib-file/composer.json
index 3bc1cc5..20b11d5 100644
--- a/php-tecnickcom-tc-lib-file/composer.json
+++ b/php-tecnickcom-tc-lib-file/composer.json
@@ -19,13 +19,13 @@
},
"require-dev": {
"apigen/apigen" : "^4.1.2",
- "bartlett/php-compatinfo" : "^5.0.0",
- "pdepend/pdepend" : "^2.2.2",
- "phploc/phploc" : "^2.1.5|^3.0.0",
- "phpmd/phpmd" : "^2.3.2",
- "phpunit/phpunit": "4.8.19|^5.0.0",
- "sebastian/phpcpd" : "^2.0.2",
- "squizlabs/php_codesniffer": "^2.5.0|^3.0.0"
+ "bartlett/php-compatinfo" : "^5.0.4",
+ "pdepend/pdepend" : "^2.5.0",
+ "phploc/phploc" : "^2.1.5 || ^3.0.1",
+ "phpmd/phpmd" : "^2.6.0",
+ "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.0",
+ "sebastian/phpcpd" : "^2.0.4 || 3.0.0",
+ "squizlabs/php_codesniffer": "^2.8.0 || ^3.0.0"
},
"autoload": {
"psr-4":{
diff --git a/php-tecnickcom-tc-lib-file/php-tecnickcom-tc-lib-file.spec b/php-tecnickcom-tc-lib-file/php-tecnickcom-tc-lib-file.spec
index bd4da34..b43dee6 100644
--- a/php-tecnickcom-tc-lib-file/php-tecnickcom-tc-lib-file.spec
+++ b/php-tecnickcom-tc-lib-file/php-tecnickcom-tc-lib-file.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 25883874ca399300d2b631034c6a89817204631d
+%global gh_commit 69a5aed25e0a98b1f7c86b2aa9ede38ff18146ee
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.6.4
+Version: 1.6.5
Release: 1%{?dist}
Summary: PHP library to read byte-level data from files
@@ -86,9 +86,14 @@ EOF
sed -i 's:src:File:g' -i test/DirTest.php
ret=0
-for cmd in php56 php70 php71 php; do
+for cmd in php56 php; do
if which $cmd; then
- $cmd %{_bindir}/phpunit --verbose || ret=1
+ $cmd %{_bindir}/phpunit --no-coverage --verbose || ret=1
+ fi
+done
+for cmd in php70 php71; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit6 --no-coverage --verbose || ret=1
fi
done
exit $ret
@@ -113,6 +118,9 @@ rm -rf %{buildroot}
%changelog
+* Sun Feb 12 2017 Remi Collet <remi@remirepo.net> - 1.6.5-1
+- update to 1.6.5 (no change)
+
* Mon Feb 6 2017 Remi Collet <remi@remirepo.net> - 1.6.4-1
- update to 1.6.4 (no change)