summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-02-12 16:55:17 +0100
committerRemi Collet <fedora@famillecollet.com>2017-02-12 16:55:17 +0100
commitd7d3980b02b610bf269098382e45dc5d7d27d026 (patch)
tree155b7452f04f6606b64bf8d4e6d1d05fec0907d5
parent387461122be8b9310fb025abb7a110d58cb949b9 (diff)
php-tecnickcom-tc-lib-barcode: 1.15.6
-rw-r--r--php-tecnickcom-tc-lib-barcode/composer.json16
-rw-r--r--php-tecnickcom-tc-lib-barcode/php-tecnickcom-tc-lib-barcode.spec14
2 files changed, 19 insertions, 11 deletions
diff --git a/php-tecnickcom-tc-lib-barcode/composer.json b/php-tecnickcom-tc-lib-barcode/composer.json
index e3b1e86..05d4df6 100644
--- a/php-tecnickcom-tc-lib-barcode/composer.json
+++ b/php-tecnickcom-tc-lib-barcode/composer.json
@@ -18,17 +18,17 @@
"ext-date": "*",
"ext-gd": "*",
"ext-pcre": "*",
- "tecnickcom/tc-lib-color": "^1.12.4"
+ "tecnickcom/tc-lib-color": "^1.12.6"
},
"require-dev": {
"apigen/apigen" : "^4.1.2",
- "bartlett/php-compatinfo" : "^5.0.0",
- "pdepend/pdepend" : "^2.2.2",
- "phploc/phploc" : "^2.1.5|^3.0.0",
- "phpmd/phpmd" : "^2.3.2",
- "phpunit/phpunit": "4.8.19|^5.0.0",
- "sebastian/phpcpd" : "^2.0.2",
- "squizlabs/php_codesniffer": "^2.5.0|^3.0.0"
+ "bartlett/php-compatinfo" : "^5.0.4",
+ "pdepend/pdepend" : "^2.5.0",
+ "phploc/phploc" : "^2.1.5 || ^3.0.1",
+ "phpmd/phpmd" : "^2.6.0",
+ "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.0",
+ "sebastian/phpcpd" : "^2.0.4 || 3.0.0",
+ "squizlabs/php_codesniffer": "^2.8.0 || ^3.0.0"
},
"autoload": {
"psr-4":{
diff --git a/php-tecnickcom-tc-lib-barcode/php-tecnickcom-tc-lib-barcode.spec b/php-tecnickcom-tc-lib-barcode/php-tecnickcom-tc-lib-barcode.spec
index 3d19bdd..0506d85 100644
--- a/php-tecnickcom-tc-lib-barcode/php-tecnickcom-tc-lib-barcode.spec
+++ b/php-tecnickcom-tc-lib-barcode/php-tecnickcom-tc-lib-barcode.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 2057d4c7a7f4397546f06d4f46eb7bbcd2955535
+%global gh_commit 18b8b9224c995cd9d7518e8551be833cbc31b323
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.15.5
+Version: 1.15.6
Release: 1%{?dist}
Summary: PHP library to generate linear and bidimensional barcodes
@@ -110,11 +110,16 @@ require __DIR__ . '/../test/TestStrings.php';
EOF
ret=0
-for cmd in php56 php70 php71 php; do
+for cmd in php56 php; do
if which $cmd; then
$cmd %{_bindir}/phpunit --verbose || ret=1
fi
done
+for cmd in php70 php71; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit6 --verbose || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
@@ -135,6 +140,9 @@ rm -rf %{buildroot}
%changelog
+* Sun Feb 12 2017 Remi Collet <remi@fedoraproject.org> - 1.15.6-1
+- update to 1.15.6 (no change)
+
* Mon Feb 6 2017 Remi Collet <remi@fedoraproject.org> - 1.15.5-1
- update to 1.15.5 (no change)