summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-02-12 16:50:58 +0100
committerRemi Collet <fedora@famillecollet.com>2017-02-12 16:50:58 +0100
commit387461122be8b9310fb025abb7a110d58cb949b9 (patch)
treec417436d0a92eb5c7e28a23d4946f93d86ed1366
parent78135e8abeb2ea90835957b135e616fed841ca13 (diff)
php-tecnickcom-tc-lib-color: 1.12.6
-rw-r--r--php-tecnickcom-tc-lib-color/composer.json14
-rw-r--r--php-tecnickcom-tc-lib-color/php-tecnickcom-tc-lib-color.spec14
2 files changed, 18 insertions, 10 deletions
diff --git a/php-tecnickcom-tc-lib-color/composer.json b/php-tecnickcom-tc-lib-color/composer.json
index aa77c42..e8f4f9c 100644
--- a/php-tecnickcom-tc-lib-color/composer.json
+++ b/php-tecnickcom-tc-lib-color/composer.json
@@ -18,13 +18,13 @@
},
"require-dev": {
"apigen/apigen" : "^4.1.2",
- "bartlett/php-compatinfo" : "^5.0.0",
- "pdepend/pdepend" : "^2.2.2",
- "phploc/phploc" : "^2.1.5|^3.0.0",
- "phpmd/phpmd" : "^2.3.2",
- "phpunit/phpunit": "4.8.19|^5.0.0",
- "sebastian/phpcpd" : "^2.0.2",
- "squizlabs/php_codesniffer": "^2.5.0|^3.0.0"
+ "bartlett/php-compatinfo" : "^5.0.4",
+ "pdepend/pdepend" : "^2.5.0",
+ "phploc/phploc" : "^2.1.5 || ^3.0.1",
+ "phpmd/phpmd" : "^2.6.0",
+ "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.0",
+ "sebastian/phpcpd" : "^2.0.4 || 3.0.0",
+ "squizlabs/php_codesniffer": "^2.8.0 || ^3.0.0"
},
"autoload": {
"psr-4":{
diff --git a/php-tecnickcom-tc-lib-color/php-tecnickcom-tc-lib-color.spec b/php-tecnickcom-tc-lib-color/php-tecnickcom-tc-lib-color.spec
index 6b6a618..caa1413 100644
--- a/php-tecnickcom-tc-lib-color/php-tecnickcom-tc-lib-color.spec
+++ b/php-tecnickcom-tc-lib-color/php-tecnickcom-tc-lib-color.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit ba1c4a9debecb0da843c13861b602a23127aeabf
+%global gh_commit 8921acc8e9c26bdc32c9b08989d42e428af6c660
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.12.4
+Version: 1.12.6
Release: 1%{?dist}
Summary: PHP library to manipulate various color representations
@@ -87,11 +87,16 @@ require '%{buildroot}%{php_project}/autoload.php';
EOF
ret=0
-for cmd in php56 php70 php71 php; do
+for cmd in php56 php; do
if which $cmd; then
$cmd %{_bindir}/phpunit --verbose || ret=1
fi
done
+for cmd in php70 php71; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit6 --verbose || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
@@ -114,6 +119,9 @@ rm -rf %{buildroot}
%changelog
+* Sun Feb 12 2017 Remi Collet <remi@fedoraproject.org> - 1.12.6-1
+- update to 1.12.6 (no change)
+
* Mon Feb 6 2017 Remi Collet <remi@fedoraproject.org> - 1.12.4-1
- update to 1.12.4 (no change)