summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-03-13 15:15:11 +0100
committerRemi Collet <fedora@famillecollet.com>2017-03-13 15:15:11 +0100
commit98e414be9cdb96e2597eab98991c99fcf13cb1f3 (patch)
tree2f60f04800116a0b8a8a63115f9a45d20e27ba00
parent1bf725d053524be5f3c8d2ac2a560a40705881d4 (diff)
wip
-rw-r--r--php-tecnickcom-tc-lib-barcode/php-tecnickcom-tc-lib-barcode.spec15
-rw-r--r--php-tecnickcom-tc-lib-color/php-tecnickcom-tc-lib-color.spec21
-rw-r--r--php-tecnickcom-tc-lib-file/php-tecnickcom-tc-lib-file.spec13
3 files changed, 36 insertions, 13 deletions
diff --git a/php-tecnickcom-tc-lib-barcode/php-tecnickcom-tc-lib-barcode.spec b/php-tecnickcom-tc-lib-barcode/php-tecnickcom-tc-lib-barcode.spec
index 0506d85..74e8fb0 100644
--- a/php-tecnickcom-tc-lib-barcode/php-tecnickcom-tc-lib-barcode.spec
+++ b/php-tecnickcom-tc-lib-barcode/php-tecnickcom-tc-lib-barcode.spec
@@ -28,7 +28,12 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
%if %{with_tests}
# For tests
-BuildRequires: php-composer(phpunit/phpunit)
+%if 0%{?fedora} >= 26
+%global phpunit %{_bindir}/phpunit6
+%else
+%global phpunit %{_bindir}/phpunit
+%endif
+BuildRequires: %{phpunit}
BuildRequires: php(language) >= 5.4
BuildRequires: php-composer(%{c_vendor}/tc-lib-color) >= 1.12.1
BuildRequires: php-bcmath
@@ -109,8 +114,11 @@ require '%{php_project}/../Color/autoload.php';
require __DIR__ . '/../test/TestStrings.php';
EOF
+%{phpunit} --no-coverage --verbose
+
+#remirepo:12
ret=0
-for cmd in php56 php; do
+for cmd in php56; do
if which $cmd; then
$cmd %{_bindir}/phpunit --verbose || ret=1
fi
@@ -140,8 +148,9 @@ rm -rf %{buildroot}
%changelog
-* Sun Feb 12 2017 Remi Collet <remi@fedoraproject.org> - 1.15.6-1
+* Sun Feb 12 2017 Remi Collet <remi@remirepo.net.org> - 1.15.6-1
- update to 1.15.6 (no change)
+- use phpunit6 on F26+
* Mon Feb 6 2017 Remi Collet <remi@fedoraproject.org> - 1.15.5-1
- update to 1.15.5 (no change)
diff --git a/php-tecnickcom-tc-lib-color/php-tecnickcom-tc-lib-color.spec b/php-tecnickcom-tc-lib-color/php-tecnickcom-tc-lib-color.spec
index caa1413..c383c72 100644
--- a/php-tecnickcom-tc-lib-color/php-tecnickcom-tc-lib-color.spec
+++ b/php-tecnickcom-tc-lib-color/php-tecnickcom-tc-lib-color.spec
@@ -28,7 +28,12 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
%if %{with_tests}
# For tests
-BuildRequires: php-composer(phpunit/phpunit)
+%if 0%{?fedora} >= 26
+%global phpunit %{_bindir}/phpunit6
+%else
+%global phpunit %{_bindir}/phpunit
+%endif
+BuildRequires: %{phpunit}
BuildRequires: php(language) >= 5.4
Requires: php-pcre
%endif
@@ -87,14 +92,13 @@ require '%{buildroot}%{php_project}/autoload.php';
EOF
ret=0
-for cmd in php56 php; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit --verbose || ret=1
- fi
-done
-for cmd in php70 php71; do
+for cmd in "php %{phpunit}" \
+ "php56 %{_bindir}/phpunit" \
+ "php70 %{_bindir}/phpunit" \
+ "php70 %{_bindir}/phpunit6" \
+ "php71 %{_bindir}/phpunit6"; do
if which $cmd; then
- $cmd %{_bindir}/phpunit6 --verbose || ret=1
+ $cmd --no-coverage --verbose || ret=1
fi
done
exit $ret
@@ -121,6 +125,7 @@ rm -rf %{buildroot}
%changelog
* Sun Feb 12 2017 Remi Collet <remi@fedoraproject.org> - 1.12.6-1
- update to 1.12.6 (no change)
+- use phpunit6 on F26+
* Mon Feb 6 2017 Remi Collet <remi@fedoraproject.org> - 1.12.4-1
- update to 1.12.4 (no change)
diff --git a/php-tecnickcom-tc-lib-file/php-tecnickcom-tc-lib-file.spec b/php-tecnickcom-tc-lib-file/php-tecnickcom-tc-lib-file.spec
index b43dee6..56d958e 100644
--- a/php-tecnickcom-tc-lib-file/php-tecnickcom-tc-lib-file.spec
+++ b/php-tecnickcom-tc-lib-file/php-tecnickcom-tc-lib-file.spec
@@ -28,7 +28,12 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
%if %{with_tests}
# For tests
-BuildRequires: php-composer(phpunit/phpunit)
+%if 0%{?fedora} >= 26
+%global phpunit %{_bindir}/phpunit6
+%else
+%global phpunit %{_bindir}/phpunit
+%endif
+BuildRequires: %{phpunit}
BuildRequires: php(language) >= 5.4
BuildRequires: php-curl
BuildRequires: php-pcre
@@ -85,8 +90,11 @@ EOF
sed -i 's:src:File:g' -i test/DirTest.php
+%{phpunit} --no-coverage --verbose
+
+#remirepo:12
ret=0
-for cmd in php56 php; do
+for cmd in php56; do
if which $cmd; then
$cmd %{_bindir}/phpunit --no-coverage --verbose || ret=1
fi
@@ -120,6 +128,7 @@ rm -rf %{buildroot}
%changelog
* Sun Feb 12 2017 Remi Collet <remi@remirepo.net> - 1.6.5-1
- update to 1.6.5 (no change)
+- use phpunit6 on F26+
* Mon Feb 6 2017 Remi Collet <remi@remirepo.net> - 1.6.4-1
- update to 1.6.4 (no change)